Bug 119893 - Evolution doesn't launch Mozilla when clicking on a link inside a message
Evolution doesn't launch Mozilla when clicking on a link inside a message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-04-02 17:10 EST by Julien Olivier
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-22 10:48:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Olivier 2004-04-02 17:10:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
In Fedora Core 2 test2, if you click on a link in a message window,
nothing happens.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open a message containing a link
2.Click on the link
    

Actual Results:  Nothing happens

Expected Results:  Mozilla show start and the link should be opened in it

Additional info:
Comment 1 Julien Olivier 2004-04-02 18:30:53 EST
I found out what the problem is: by default, in "preferences -> file
types and programs -> internet services", the http protocol is set to
"mozilla-1.6 %s" and the https protocol is set to "epiphany %s".

On my computer, mozilla's binary is /usr/bin/mozilla, not
/usr/bin/mozilla-1.6 and I don't have epiphany installed.

I changed both protocols to "mozilla %s" , and now it works fine.

I guess the solution is to have this keys automatically changed to
something that is installed between mozilla, epiphany or konqueror.

PS: it was tested on both a fresh account and an old account.
Comment 2 petrosyan 2004-04-04 18:28:47 EDT
what does 
$rpm -q mozilla
say ?
Comment 3 Julien Olivier 2004-04-05 03:55:31 EDT
[julien@rfc1918 julien]$ rpm -q mozilla
mozilla-1.6-2
Comment 4 Warren Togami 2004-04-10 23:45:53 EDT
I suspect this is fixed by newer versions of control-center, but not
in the default schema.  Try the following procedurE:
1) Upgrade to latest rawhide.
2) Run Preferences -> Preferred Applications.
3) Choose the browser that you wish to run when clicking on links.

Restart Evolution and see if it behaves any better with both http and
https links.  Please report your results.
Comment 5 Julien Olivier 2004-04-11 08:36:13 EDT
I've tested it on both my current account (removing http and https
protocols from "file types & programs") and on a newly created account
and it works well.

That said, on the newly created account, there was no browser defined
in preferred applications. I think the preferred browser should be
automatically set (only the first time) to the first browser found
among a list containing Mozilla, Konqueror and Epiphany.
Comment 6 Warren Togami 2004-04-11 08:41:48 EDT
This is after using latest rawhide control-center?
Comment 7 Warren Togami 2004-04-11 08:42:27 EDT
The desktop team needs to make certain decisions about which browser
will be default, but it will be a sane default so things like this
work without any configuration needed.
Comment 8 Julien Olivier 2004-04-11 08:50:41 EDT
Yes, I'm using "Gnome control-center 2.6.0.3". I did a yum update just
before testing it.
Comment 9 Sean Earp 2004-04-18 15:35:22 EDT
This is a dupe of bug 119569.  The problem is fixed as of
gnome-vfs2-2.6.0-5 (which changes the default browser from epiphany -
which is not installed - to Mozilla).  Update gnome-vfs2 and create a
new user account to test.
Comment 10 Julien Olivier 2004-04-18 15:59:41 EDT
OK, I've tested it on a new account, and it works perfectly.

Note You need to log in before you can comment on or make changes to this bug.