Bug 1198957 - PCLConfig.cmake expects vtk libraries that are not found in EPEL for RHEL6
Summary: PCLConfig.cmake expects vtk libraries that are not found in EPEL for RHEL6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pcl
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Niemueller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-05 08:11 UTC by bugreports2005
Modified: 2015-04-20 18:37 UTC (History)
2 users (show)

Fixed In Version: pcl-1.7.1-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-20 18:37:11 UTC


Attachments (Terms of Use)

Description bugreports2005 2015-03-05 08:11:13 UTC
Description of problem:

/usr/lib64/cmake/pcl/PCLConfig.cmake has this from line 287 onwards:

  if (VTK_FOUND AND NOT ANDROID)
    set(VTK_LIBRARIES vtkCommonCore vtkRenderingCore)
  endif(VTK_FOUND AND NOT ANDROID)

But the vtk package from EPEL for RHEL6 doesn't seem to provide the vtkCommonCore or the vtkRenderingCore libraries. From a glance it looks like these may have made their appearance with vtk 6, but the version of in EPEL for RHEL6 is 5.8.0.


Version-Release number of selected component (if applicable):

pcl-1.7.1-7.el6.x86_64
pcl-devel-1.7.1-7.el6.x86_64
vtk-5.8.0-6.el6.1.x86_64
vtk-devel-5.8.0-6.el6.1.x86_64


How reproducible:

Always


Steps to Reproduce:
1. Install pcl-devel and vtk-devel from EPEL for RHEL6
2. get pcd_write.cpp and CMakeLists.txt from http://pointclouds.org/documentation/tutorials/writing_pcd.php
3. mkdir build; cd build; cmake ..; make


Actual results:

Linking CXX executable pcd_write
/usr/bin/ld: cannot find -lvtkCommonCore


Expected results:

Linking CXX executable pcd_write
[100%] Built target pcd_write


Additional info:

Removing the lines from PCLConfig.cmake or altering ones CMakeLists.txt to read like this will allow the example program to build:

find_package(PCL 1.2 REQUIRED)
list(REMOVE_ITEM PCL_LIBRARIES vtkCommonCore vtkRenderingCore)

I cannot tell if this is a good workaround, though.

Comment 1 Rich Mattes 2015-03-24 23:51:08 UTC
Thanks for the report.  It was indeed a breakage while working out compatibility with vtk6.  It was fixed upstream in 1.7.2, so I'm backporting the fix to the el6 1.7.1.  You shouldn't need the workaround with the fixed package.

Keep an eye on this bug report for instructions on how to test, and report back if you have problems with the update.

Comment 2 Fedora Update System 2015-03-25 00:59:49 UTC
pcl-1.7.1-8.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pcl-1.7.1-8.el6

Comment 3 Fedora Update System 2015-03-25 20:04:06 UTC
Package pcl-1.7.1-8.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing pcl-1.7.1-8.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-1408/pcl-1.7.1-8.el6
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2015-04-20 18:37:11 UTC
pcl-1.7.1-8.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.