Bug 1199039 - with -object memory-backend-ram and -sandbox on, the guest will fail
Summary: with -object memory-backend-ram and -sandbox on, the guest will fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-05 11:27 UTC by Yanhui Ma
Modified: 2015-12-04 16:31 UTC (History)
7 users (show)

Fixed In Version: qemu-2.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-04 16:31:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Yanhui Ma 2015-03-05 11:27:36 UTC
Description of problem:
When I append -object memory-backend-ram and -sandbox on together, guest will fail.

Version-Release number of selected component (if applicable):

qemu-kvm-rhev-2.2.0-5.el7.x86_64
3.10.0-229.el7.x86_64

How reproducible:


Steps to Reproduce:
1.boot a guest with -object memory-backend-ram and -sandbox on together
/usr/libexec/qemu-kvm -M pc-i440fx-rhel7.1.0 -m 4G 
-cpu Opteron_G3,hv_relaxed,hv_vapic,hv_spinlocks=0x1fff,hv_time -smp 4,sockets=2,cores=2,threads=1 
-monitor stdio -vga std -vnc :2 
-device virtio-scsi-pci,id=scsi1,bus=pci.0,addr=0x7 -drive file=/home/win_server_2012r2_x64.qcow2,if=none,id=drive-data-disk1,cache=none,format=qcow2,aio=threads,werror=stop,rerror=stop -device scsi-hd,drive=drive-data-disk1,bus=scsi1.0,id=data-disk1,bootindex=0 
-device virtio-scsi-pci,bus=pci.0,addr=0xc,id=scsi2 -drive file=/home/data-disk-test.qcow2,if=none,id=drive-scsi2-0-0,media=disk,cache=none,format=qcow2,werror=stop,rerror=stop,aio=threads -device scsi-hd,drive=drive-scsi2-0-0,bus=scsi2.0,scsi-id=0,lun=0,id=yama2 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=virtio-net-pci0,mac=00:24:21:7f:b6:11,bus=pci.0,addr=0x9 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 
-global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 
-object memory-backend-ram,host-nodes=0,id=mem-0,policy=bind,prealloc=yes,size=2G -numa node,nodeid=0,memdev=mem-0 -object memory-backend-ram,host-nodes=0,id=mem-1,policy=bind,prealloc=yes,size=2G -numa node,nodeid=1,memdev=mem-1 
-sandbox on -usb -device usb-tablet,id=input0 -device usb-host,hostbus=002,hostaddr=005,id=hostdev0
2.
3.

Actual results:
Guest cann't boot. print the "Bad system call"

Expected results:
Guest boot successfully

Additional info:

Comment 2 FuXiangChun 2015-03-05 14:35:48 UTC
As qemu-kvm-rhev-2.1.2-23.el7.x86_64 didn't hit this issue and this bug is fixed by bug 1172473.  So this is a regression bug.

Comment 5 Lin Chen 2015-06-23 07:20:27 UTC
reproduce:
host kernel:3.10.0-267.el7.x86_64
host qemu:  qemu-kvm-rhev-2.2.0-8.el7.x86_64

QE retested this bug on the above environment,then got the same result.
So, the bug is reproduced on the above environment.


verify:
host kernel:3.10.0-267.el7.x86_64
host qemu:  qemu-kvm-rhev-2.3.0-4.el7.x86_64

QE retested this bug on the above environment. Appended -object memory-backend-ram and -sandbox on together, guest boot successfully.
So, the bug fixed.

Comment 9 errata-xmlrpc 2015-12-04 16:31:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.