Bug 119914 - xorg hanges with nvidia driver 1.0-5336
xorg hanges with nvidia driver 1.0-5336
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 22:23 EST by Denis Yeldandi
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denis Yeldandi 2004-04-02 22:23:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
I upgraded FC1 to FC2-test2. After I installed nvidia drivers from
nvidia site xorg couldn't start saying it couldn't load nvidia driver.
That is with kernel 2.6.4-300. With kernel -303 it just hangs when it
is to run xorg.

Version-Release number of selected component (if applicable):
xorg-0.0.6.6-0.0.2004_03_11.9

How reproducible:
Always

Steps to Reproduce:
1.Install fc2-test2
2.Go to www.nvidia.com, download drivers, install them
3.Run xorg
    

Actual Results:  xorg does not start or hangs depending on the kernel

Expected Results:  It should have started.

Additional info:

When I changed to nv driver DRI is not loaded.
Comment 1 Erwin J. Prinz 2004-04-02 22:45:26 EST
I have had the same experience with an NVIDIA card which works with
the FC2T2 "nv" driver and has worked on FC1 with the NVIDIA binary
drivers 1.0-5336.
A "solution" has already been reported in the NVIDIA forum at
http://www.nvnews.net/vbulletin/showthread.php?t=26745.
It consists of recompiling the kernel with a different option.
Comment 2 Mike A. Harris 2004-04-03 00:49:42 EST

*** This bug has been marked as a duplicate of 73733 ***
Comment 3 Joshua Weage 2004-05-19 15:15:03 EDT
Why is it that Fedora/RedHat kernels are compiled with options that
are known to cause problems with NVIDIA drivers?

The NVIDIA binary modules are not an option for my employer, they are
a requirement.  The OpenGL performance of the nv module is simply
unacceptable.  If Fedora/RedHat makes users jump through hoops to get
the NVIDIA drivers working, we are going to switch to a distribution
that works with NVIDIA drivers out of the box (SUSE for example).

Comment 4 David Fraser 2004-05-19 15:36:16 EDT
It should be a fairly simple matter for NVidia to update their drivers
to handle the new kernel options. The kernel is the bigger, more
important piece of software and is doing far more than just supporting
NVidia drivers.
But by not releasing the source, NVidia makes life more difficult for
distributions and users. Rather than complain to RedHat, complain to
NVidia and ask them to
a) release the source
or at least
b) release new binary drivers that work with the new options
Comment 5 Joshua Weage 2004-05-19 16:45:33 EDT
There are two kernel options that cause the NVIDIA driver problems. 
CONFIG_4STACKS and CONFIG_REGPARMS.  Both are added by the Fedora team
and are apparently development level, not stable, options in 2.6.6. 
The NVIDIA modules do work fine with 2.6 kernels with non-development
level configurations.

Other distributions do not have these options turned on, so why does
Fedora?  In particular, why does Fedora do this when binary graphics
drivers are mandatory for decent performance with any 3D application?
 Wouldn't it make more sense to leave these options off and allow
users who require these options to recompile a custom kernel?

I would think that supporting OpenGL applications is far more
important than freeing up a small amount of RAM to support hundreds of
threads on Java database server.
Comment 6 John Dennis 2004-05-20 13:03:39 EDT
Fedora is a cutting edge distribution designed to drive technology
forward with diverse goals. If proprietary drivers in a production
environment is central to your needs then a release designed for
stable enterprise class environments seems better suited to your needs
than Fedora. Have you considered a Red Hat Enterprise product, it's
goals seem more in line with your needs. We encourage 3rd party
vendors to focus on RHEL because of its more stable and slower release
model and as a consequence 3rd party products are much more likely to
function well  with such a product than with a distribution whose goal
is rapid turn around and the integration of new software elements. You
also need to keep in mind that NVidia has a role to play in this too
and needs to be an active participant. You can help as one of their
customers by expressing your desire for better support and testing of
their products and making them aware how important this is to you.
There is more than one player involved when it comes to a major OS
distribution serving multiple target audiences. The more Nvidia hears
the more they will participate. Make sense? To be perfectly honest I
don't think anyone participating in Fedora, which is open source and
community driven, had any idea this was going to break a 3rd party
proprietary driver nor is it a goal of Fedora to ensure 3rd party
closed source proprietary products are unaffected by the evolution the
OS. Please consider a Red Hat product designed for your needs, our
enterprise distributions.
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.