Bug 119915 - /etc/hosts file with networking leads to X problems
Summary: /etc/hosts file with networking leads to X problems
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2004-04-03 03:53 UTC by Erwin J. Prinz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Clone Of:
Last Closed: 2004-11-04 13:57:16 UTC

Attachments (Terms of Use)

Description Erwin J. Prinz 2004-04-03 03:53:58 UTC
Description of problem:
I have enabled networking during the FC2T2 install. I set parameters
manually, not using dhcpd.
/etc/network then becomes:


and /etc/hosts becomes:

# Do not remove the following line, or various programs
# that require network functionality will fail.		erwin.prinz erwin localhost.localdomain localhost

After logging in, I cannot start applications such as xterm, xemacs,
etc. But, if I change the /etc/hosts file to read:

# Do not remove the following line, or various programs
# that require network functionality will fail.		localhost.localdomain localhost		tiger.prinz tiger

the problem is resolved.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Generate /etc/hosts file as shown above.
2. Try to run xterm from a console.
3. Wait ... wait ... wait
4. Change modified /etc/hosts file as shown above.
5. Try to run xterm.
6. It works.

Actual Results:  See above.

Expected Results:  This seems to be an issue between anaconda, x.org,
and maybe pam(?). One solution is to change anaconda to create an
/etc/hosts file as shown above.

Additional info:

Comment 1 Erwin J. Prinz 2004-04-05 03:05:48 UTC
From Roger Grosswiler :


tried to add a remark in Bugzilla, appending to bug#

..but cannot enter. (do not get any password...)

could anyone append to this bug:

doesn't resolve problem on DHCP?

Thanks and sorry...

Comment 2 Jeremy Katz 2004-04-05 22:17:02 UTC
Do you have that IP resolving to something different in your network

Comment 3 Erwin J. Prinz 2004-04-09 22:11:21 UTC
No, the IP resolves only to the one computer.

I have tried to reproduce the bug by installing on 2 other computers.
I found that the /etc/hosts file generated by anaconda is not the
cause of the problem, as the problem didn't occur on the other
computers despite the /etc/hosts file which looked similar to the one
on the first computer. The only difference in the install has been
that on the first computer I installed "everything" while on the other
ones I was more selective. I have since disabled numerous services
which are started from the default anaconda install and now even on
the first compouter I can change the /etc/hosts file to the one
obtained after the initial install with no problems, i.e.:

1. mv /etc/hosts /etc/hosts-orig
2. Edit /etc/hosts to contain:	localhost	localhost.localdomain	tiger	tiger.prinz	matrix	matrix.prinz	bob	bob.prinz
3. service network restart

I'll try the same procedure at the next (test3) install.

Comment 4 Jeremy Katz 2004-09-22 19:15:09 UTC
Is this better with FC2 final/FC3?

Comment 5 Jeremy Katz 2004-11-04 13:57:16 UTC
Closing due to inactivity.  Please reopen this bug if you have further
information to add to the report.

Note You need to log in before you can comment on or make changes to this bug.