Bug 1199214 - Provisioning of RHEL-7/s390x fails due to wrong kernel command line
Summary: Provisioning of RHEL-7/s390x fails due to wrong kernel command line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 570
Hardware: s390x
OS: Linux
high
high
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Jan Hutař
URL:
Whiteboard:
Depends On:
Blocks: sat570-triage
TreeView+ depends on / blocked
 
Reported: 2015-03-05 16:29 UTC by Jan Stodola
Modified: 2018-01-30 15:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-14 06:43:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1891 0 normal SHIPPED_LIVE Satellite 5.7 bug fix update 2015-10-14 10:43:04 UTC

Description Jan Stodola 2015-03-05 16:29:23 UTC
Description of problem:
Provisioning of RHEL-7.1/s390x using Satellite 5.7 fails when the installation is starting.
The installation fails because of wrong parameters on the kernel command line:

1) "ip"
"ip" without any value is refused by dracut
2) "root=/dev/ram0"
this parameter must not be present on the kernel command line when installing RHEL-7 on s390x.

Created boot record in /etc/zipl.conf contains:
[kick1425568199]
        image=/boot/kernel.img
        ramdisk=/boot/initrd.img
        parameters="ksdevice=link lang= CMSDASD=191 ip RUNKS=1 root=/dev/ram0 ks=http://something1.redhat.com/cblr/svc/op/ks/system/something2.redhat.com:1 ramdisk_size=40000 CMSCONFFILE=r7.conf text vnc ro kssendmac "

Version-Release number of selected component (if applicable):
Red Hat Satellite release 5.7.0

How reproducible:
always on s390x

Steps to Reproduce:
1. create a kickstart for provisioning RHEL-7.1
2. enter "CMSDASD=191 CMSCONFFILE=r7.conf" to the "Kernel Options" field under Kickstart Details -> Details (this is where the network and disk configuration is stored on our systems)
3. provision an s390x system using the kickstart

Actual results:
wrong kernel command line, system fails to install

Expected results:
successful installation, "ip" and "root=/dev/ram0" are not present on the installation kernel command line

Additional info:
* "root=/dev/ram0" has been removed from the installation kernel command line in RHEL-7.0, see bug 796572
* "root=/dev/ram0" is a valid parameter for RHEL-6 and earlier

Comment 2 Jan Stodola 2015-03-05 16:32:32 UTC
Workaround is to remove "ip" and "root=/dev/ram0" from /etc/zipl.conf and run "zipl" before rebooting to start the installation.

Comment 3 Jan Dobes 2015-09-03 11:24:07 UTC
removed in spacewalk master:

da2cf6dd0d69acbf45afc73272b2073691651c03

Comment 8 Jan Dobes 2015-10-05 12:40:29 UTC
fixed in spacewalk master:

dca931ce2792c1da2f5dd49c9f859cf148c1feb7

Comment 15 errata-xmlrpc 2015-10-14 06:43:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1891.html


Note You need to log in before you can comment on or make changes to this bug.