Bug 1199345 - Missing dependencies in virt-install
Summary: Missing dependencies in virt-install
Keywords:
Status: CLOSED DUPLICATE of bug 1195794
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-06 02:01 UTC by Lars Kellogg-Stedman
Modified: 2015-03-24 23:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-24 23:00:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Lars Kellogg-Stedman 2015-03-06 02:01:24 UTC
The "virt-install" command requires the "gi.repository" module, which is provided by the "pygobject3-base" package.  If this package is not installed, virt-install fails with:

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-install", line 29, in <module>
    import virtinst
  File "/usr/share/virt-manager/virtinst/__init__.py", line 85, in <module>
    from virtinst.distroinstaller import DistroInstaller
  File "/usr/share/virt-manager/virtinst/distroinstaller.py", line 28, in <module>
    from . import osdict
  File "/usr/share/virt-manager/virtinst/osdict.py", line 26, in <module>
    from gi.repository import Libosinfo as libosinfo
ImportError: No module named gi.repository

The spec file should be updated to add the required dependency.

Comment 1 Cole Robinson 2015-03-24 23:00:39 UTC

*** This bug has been marked as a duplicate of bug 1195794 ***


Note You need to log in before you can comment on or make changes to this bug.