Bug 1199355 - screen shows garbage during install guest os
Summary: screen shows garbage during install guest os
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 6.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Christophe Fergeau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks: 1222040
TreeView+ depends on / blocked
 
Reported: 2015-03-06 02:59 UTC by mazhang
Modified: 2019-06-13 08:17 UTC (History)
16 users (show)

Fixed In Version: xorg-x11-drv-qxl-0.1.1-17.el6
Doc Type: Bug Fix
Doc Text:
Cause: memory leak in the cursor handling code of the QXL guest driver Consequence: video memory would get saturated, and would cause corrupted display when anaconda is formatting a huge disk (2TB+) Fix: don't leak the cursor data Result: no display corruption.
Clone Of:
: 1222040 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:32:02 UTC


Attachments (Terms of Use)
screen snapshot (44.38 KB, image/png)
2015-03-06 03:00 UTC, mazhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1399 normal SHIPPED_LIVE xorg-x11-drv-qxl bug fix update 2015-07-20 18:07:22 UTC

Description mazhang 2015-03-06 02:59:35 UTC
Description of problem:
Install os on a big image(2T), screen shows garbage during format disk.

Version-Release number of selected component (if applicable):

Host:
2.6.32-539.el6.x86_64
qemu-kvm-0.12.1.2-2.456.el6.x86_64

Guest:
RHEL6.6 GA

How reproducible:
always

Steps to Reproduce:
1.Create a big image.
#qemu-img create -f qcow2 big.img 2T

2.Start qemu-kvm with following command line.
/usr/libexec/qemu-kvm \
-M pc \
-cpu SandyBridge \
-m 2G \
-smp 4,sockets=2,cores=2,threads=1 \
-enable-kvm \
-name rhel6 \
-uuid 990ea161-6b67-47b2-b803-19fb01d30d12 \
-smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67170 \
-k en-us \
-rtc base=localtime,driftfix=slew \
-nodefaults \
-monitor stdio \
-qmp tcp:0:6779,server,nowait \
-boot menu=on \
-bios /usr/share/seabios/bios.bin \
-serial unix:/tmp/console0,server,nowait \
-spice port=5900,disable-ticketing \
-vga qxl \
-drive file=/home/big.img,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,werror=stop,rerror=stop,aio=threads \
-device virtio-blk-pci,scsi=off,bus=pci.0,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1,serial="QEMU-disk0" \
-usb -device usb-tablet,id=input0 \
-drive file=/home/boot.iso,if=none,media=cdrom,id=drive-ide0,readonly=on,format=raw \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0,id=ide0,bootindex=0 \
-netdev tap,id=tap1,vhost=on \
-device virtio-net-pci,netdev=tap1,id=nic1,mac=52:54:00:ae:f9:55 \

3.

Actual results:
Screen shows garbage during format disk(format disk will take a long time).

Expected results:
Display normal.

Additional info:
Use vga std not hit this problem.

Comment 1 mazhang 2015-03-06 03:00:39 UTC
Created attachment 998637 [details]
screen snapshot

Comment 3 Gerd Hoffmann 2015-03-09 09:03:19 UTC
Happens on RHEL-7 host too.
Looks like a guest bug.
Assigning to xorg qxl driver for investigation.

Comment 4 Marc-Andre Lureau 2015-03-10 13:11:42 UTC
What is boot.iso? If it's the RHEL6 installer, is it using the QXL driver? (try to get the Xorg log during install)

(if not, it looks like a VGA emulation bug, and should be reassigned to qemu)

Comment 5 Christophe Fergeau 2015-03-10 17:15:46 UTC
Happens with a rhel 6.6 server iso, and the installer is using QXL. Happens when big.img grows to about 5GB here. Could not get useful logs at this point.

Comment 6 Christophe Fergeau 2015-03-11 10:52:47 UTC
After managing to get an ssh connection to the VM (add 'sshd' to the boot options, and then enable eth0 in the graphical installer), I've managed to get

[   722.011] Out of memory allocating 31460 bytes
[   722.011] Out of mem - stats

[   722.015] max system bytes =   50319360
[   722.015] system bytes     =   50319360
[   722.015] in use bytes     =   48957432

Comment 7 Christophe Fergeau 2015-03-24 13:33:11 UTC
http://lists.freedesktop.org/archives/spice-devel/2015-March/019229.html fixes the issue for me.

Comment 8 mazhang 2015-03-31 02:30:26 UTC
Remove needinfo.

Comment 9 David Jaša 2015-04-01 00:50:01 UTC
reproduced according to instructions. The disk size rose to 32 GB in my case however.

Comment 18 Christophe Fergeau 2015-05-29 11:48:59 UTC
If you copied the fixed QXL rpm to the iso in the Packages dir, I think you changed the QXL driver which would be used after the installation completes. the driver which is used during the installation must be embedded uncompressed in some .img file or such which is uncompressed/loopback mounted before the installation starts. Ie not that trivial to upgrade the installer.

What I did was that I started from a RHEL6.6/6.7 system, upgraded the QXL driver to the latest version, yum install'ed anaconda (https://brewweb.devel.redhat.com/packageinfo?packageID=98 ), and then opened a root terminal, and started anaconda from there. So quite different from booting the installer directly from the ISO, but much easier. If you want to try an installer, there are probably some 6.7 installer isos with the right driver (?)

Comment 20 errata-xmlrpc 2015-07-22 07:32:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1399.html


Note You need to log in before you can comment on or make changes to this bug.