Bug 1199397 - virt-who uses wrong server when connecting to satellite
Summary: virt-who uses wrong server when connecting to satellite
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who
Version: 6.7
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Radek Novacek
QA Contact: gaoshang
URL:
Whiteboard:
Depends On: 1158859
Blocks: 1205520
TreeView+ depends on / blocked
 
Reported: 2015-03-06 06:41 UTC by Masaki Furuta
Modified: 2019-09-12 08:17 UTC (History)
13 users (show)

Fixed In Version: virt-who-0.12-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, virt-who used the value of the "--esx-server" command-line option instead of the "--satellite-server" option value. As a consequence, virt-who attempted to report a host-guest association to the ESX server instead of satellite, and thus failed. With this update, "--satellite-server" works as intended, and virt-who uses the correct server when connecting to Red Hat Satellite.
Clone Of: 1158859
: 1205520 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:16:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1377 normal SHIPPED_LIVE virt-who bug fix and enhancement update 2015-07-20 17:58:35 UTC

Comment 4 Radek Novacek 2015-03-19 11:25:43 UTC
From developer point of view, backporting the patch is trivial. But GSS or PM have to request the z-stream.

Comment 5 Radek Novacek 2015-03-19 12:41:21 UTC
This bug is fixed in y-stream by rebase of virt-who to virt-who-0.12-1.el6.

Comment 8 Liushihui 2015-04-09 06:51:26 UTC
Verified it on virt-who-0.12-2.el6.noarch

Verified version:
Satellite-5.7.0-RHEL6-re20150108.2-x86_64
virt-who-0.12-2.el6.noarch
subscription-manager-1.14.1-1.el6.x86_64

Verified process:
1. Register rhel to Satellite-5.7
2. Run virt-who in esx mode in cmd, virt-who has send host/guest associate to satellite
[root@hp-z220-06 ~]# virt-who -d -o --satellite --satellite-server=10.66.128.4 --satellite-username=virtwho_test --satellite-password=redhat123 --esx --esx-owner=virtwho_org --esx-env=Library --esx-server=https://10.66.79.72:443 --esx-username=administrator@vsphere.local --esx-password=qwer1234P!
2015-04-09 14:46:33,576 INFO: Using configuration "env/cmdline" ("esx" mode)
2015-04-09 14:46:33,697 DEBUG: Log into ESX
2015-04-09 14:46:36,258 DEBUG: Creating ESX event filter
2015-04-09 14:46:36,331 DEBUG: Getting the host/guests association took too long, interval waiting is skipped
2015-04-09 14:46:36,594 DEBUG: Initializing satellite connection to https://10.66.128.4/XMLRPC
2015-04-09 14:46:36,595 INFO: Initialized satellite connection
2015-04-09 14:46:36,595 INFO: Sending update in hosts-to-guests mapping: {aee4ff00-8c33-11e2-994a-6c3be51d959a: [], 86b2bd00-8bad-11e2-87f4-6c3be514699d: [4224e5d2-4fcf-2bc2-2559-5846035d3a78, 4224a77f-1c50-42cb-3507-2b68b447ed60]}
2015-04-09 14:46:36,596 DEBUG: Loading systemid for aee4ff00-8c33-11e2-994a-6c3be51d959a
2015-04-09 14:46:36,596 DEBUG: Loading system id info from /var/lib/virt-who/hypervisor-systemid-aee4ff00-8c33-11e2-994a-6c3be51d959a
2015-04-09 14:46:36,774 DEBUG: New system created in satellite, system id saved in /var/lib/virt-who/hypervisor-systemid-aee4ff00-8c33-11e2-994a-6c3be51d959a
2015-04-09 14:46:36,774 DEBUG: Building plan for hypervisor aee4ff00-8c33-11e2-994a-6c3be51d959a: []
2015-04-09 14:46:36,775 DEBUG: Sending plan: [[0, 'exists', 'system', {'uuid': '0000000000000000', 'identity': 'host'}], [0, 'crawl_began', 'system', {}], [0, 'crawl_ended', 'system', {}]]
2015-04-09 14:46:36,834 DEBUG: Loading systemid for 86b2bd00-8bad-11e2-87f4-6c3be514699d
2015-04-09 14:46:36,835 DEBUG: Loading system id info from /var/lib/virt-who/hypervisor-systemid-86b2bd00-8bad-11e2-87f4-6c3be514699d
2015-04-09 14:46:36,835 DEBUG: Building plan for hypervisor 86b2bd00-8bad-11e2-87f4-6c3be514699d: [4224e5d2-4fcf-2bc2-2559-5846035d3a78, 4224a77f-1c50-42cb-3507-2b68b447ed60]
2015-04-09 14:46:36,836 DEBUG: Sending plan: [[0, 'exists', 'system', {'uuid': '0000000000000000', 'identity': 'host'}], [0, 'crawl_began', 'system', {}], [0, 'exists', 'domain', {'state': 'running', 'memory_size': 0, 'name': u'VM from esx hypervisor 86b2bd00-8bad-11e2-87f4-6c3be514699d', 'virt_type': 'fully_virtualized', 'vcpus': 1, 'uuid': '4224e5d24fcf2bc225595846035d3a78'}], [0, 'exists', 'domain', {'state': 'running', 'memory_size': 0, 'name': u'VM from esx hypervisor 86b2bd00-8bad-11e2-87f4-6c3be514699d', 'virt_type': 'fully_virtualized', 'vcpus': 1, 'uuid': '4224a77f1c5042cb35072b68b447ed60'}], [0, 'crawl_ended', 'system', {}]]
3.Check the Satellite UI, two hypervisors have shown in "System"

Result: According to the result in step2 and step3, virt-who has send the host/guest mapping to Satellite , therefore, verify it.

Comment 9 errata-xmlrpc 2015-07-22 07:16:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1377.html


Note You need to log in before you can comment on or make changes to this bug.