Bug 119946 - up2date not deleting (or deleting when it should not)
up2date not deleting (or deleting when it should not)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: up2date-fc2 up2date-rhel3-u3
  Show dependency treegraph
 
Reported: 2004-04-03 17:12 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:27:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-04-03 17:12:16 EST
Description of problem:
selinux enforce ON (setenforce 1).

Using the packages from development on 3 April 04, I selected the
following for update:

arts-*
elfutils-*
policy
policy-sources
policycoreutils
selinux-doc

I ended up with two version of policy-sources in the rpm db.

While I still have everything, what information do you wnat me to capture.

Version-Release number of selected component (if applicable):
FC2T2 plus current (development) up2date and rpm-*

How reproducible:
Yes.  First time on x86_64 and then reporduced it on a ix86 system.

  
Actual results:
policy-1.9.2-9
policycoreutils-1.9.2-1
policy-sources-1.9.2-9
policy-sources-1.9.2-5


Expected results:
policy-1.9.2-9
policycoreutils-1.9.2-1
policy-sources-1.9.2-9


Additional info:
While this "did not delete old package" is clear, I have also had
occurances of a new package failing to install but up2date did not
detect this and removed the old package (leaving nothing installed). 
One of these occurances was for gdm IIRC.  What I am not sure of is if
the actual files were deleted or just the rpm DB screwed up.

I have more or less all of the updates issued since FC2T1 was released
in a local repository and could possibly recreate the situation if
needed ... but it would not be easy and I would prefer not to do that.
Comment 1 Gene Czarcinski 2004-04-03 17:21:23 EST
selected results of rpm -qa --last

selinux-doc-1.8-3                             Sat 03 Apr 2004 04:32:42
PM EST
policy-sources-1.9.2-9                        Sat 03 Apr 2004 04:32:37
PM EST
elfutils-devel-0.95-2                         Sat 03 Apr 2004 04:32:34
PM EST
elfutils-libelf-devel-0.95-2                  Sat 03 Apr 2004 04:32:33
PM EST
arts-devel-1.2.1-2                            Sat 03 Apr 2004 04:32:33
PM EST
policycoreutils-1.9.2-1                       Sat 03 Apr 2004 04:32:32
PM EST
policy-1.9.2-9                                Sat 03 Apr 2004 04:32:32
PM EST
elfutils-0.95-2                               Sat 03 Apr 2004 04:32:30
PM EST
arts-1.2.1-2                                  Sat 03 Apr 2004 04:32:29
PM EST
elfutils-libelf-0.95-2                        Sat 03 Apr 2004 04:32:09
PM EST
rp-pppoe-3.5-14                               Fri 02 Apr 2004 05:01:04
PM EST
...
rpmdb-fedora-1.91-0.20040402                  Fri 02 Apr 2004 03:52:58
PM EST
policy-sources-1.9.2-5                        Fri 02 Apr 2004 03:52:47
PM EST
libselinux-devel-1.9-1                        Fri 02 Apr 2004 03:52:45
PM EST
Comment 2 Gene Czarcinski 2004-04-07 08:08:36 EDT
It is interesting that something in up2date detected that packages had
not been processed or processed properly because the total progress
bad was not at the complete point when the "finished" message appears.
Comment 3 Adrian Likins 2004-04-07 16:09:53 EDT
er, no idea... afaik nothing in the code has changed to
cause anything to not delete (especially on "-U" style 
updates). Might be an rpm issue, trying to reproduce...
Comment 4 Daniel Walsh 2004-12-20 15:27:58 EST
I am closing this as I do not believe it happens with the latest policy.

Dan

Note You need to log in before you can comment on or make changes to this bug.