This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 11995 - #9 Revolution IV doesn't work with X.
#9 Revolution IV doesn't work with X.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
Winston should-fix
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-08 16:53 EDT by Bill Pemberton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 16:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Pemberton 2000-06-08 16:53:54 EDT
Graphical install doesn't start X.  Says it's falling back to VGA16, but
that fails also.  Machine is dual PII with AGP #9 Revolution IV.
Comment 1 Brock Organ 2000-06-08 18:09:28 EDT
could you confirm the following vendor id #s for your card? 
(probably are 105d:5348)

(ie you can use lspci and lspci -n to find the ids...)
Comment 2 Jeremy Katz 2000-06-08 22:55:43 EDT
The Revolution series of cards has been having a lot of trouble in various cases
since Red Hat 6.1 from my roommate's experience (who's since gotten rid of the
card).  In 6.1, X doesn't work at all.  In 6.2, X works but not in the
installer; thus if the XF86_I128 is the same server it may just need to be
recompiled in a proper environment.
Comment 3 Matt Wilson 2000-06-16 11:21:25 EDT
I really need those PCI ids to get this fixed.
Comment 4 Matt Wilson 2000-06-16 11:26:41 EDT
OK, I think I may have it fixed.
Comment 5 Bill Pemberton 2000-06-23 14:06:21 EDT
It's still not fixed in beta2.  I don't know if it should have been.  

Yes, the PCI ids are 105d:5348
Comment 6 Glen Foster 2000-07-18 14:20:32 EDT
This defect is considered MUST-FIX for Winston Beta-5
Comment 7 Glen Foster 2000-07-21 14:38:03 EDT
Does this defect still exist with (on) Winston beta-4?
Comment 8 Bill Pemberton 2000-07-24 10:56:39 EDT
Yes,  I still get the same failure using Beta 4.
Comment 9 Glen Foster 2000-07-30 18:25:17 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1

... we've fixed a lot of video-card problems in beta-5.  Can you check to see if
the problem still exists in Pinstripe (beta-5)?
Comment 10 Bill Pemberton 2000-07-31 10:19:31 EDT
It's still failing for me.  However, it doesn't look like it's getting as far as
trying to start X (and the text install crashes the same way).  This machine has
a zip drive in it, is that bug still in beta 5?

Comment 11 Matt Wilson 2000-08-04 15:52:31 EDT
What does the failure look like now?  "Unknown card" or something else?  You say
text mode fails too?  Can we get some more info?
Comment 12 Bill Pemberton 2000-08-04 16:04:31 EDT
Ok, doing either type of install I get:

Make it through the "Loading Buslogic Drivers" and then
gets install exited abnormally -- recieved signal 11.

Alt-F3 screen ends with
   * looking for video cards requiring agpgart module
   * found video card controller unknown
   * probing buses
   * finished bus probing
   * found suggestion of BusLogic
   * found BusLogic device
   * found suggestion of uhci
   * found devices JustProbe is 0
   * going to insmod BusLogic.o (path is NULL)
   * trying to mount device hdc
   * loopfd is 6
   * found url image cdrom://hdc/mnt/source
   * getting ready to spawn shell now

It doesn't look like it's getting as far as trying to start the X server.  This
machine does have zip drive in it, so that's why I thought that may be problem
(assuming that bug is still in this beta).
Comment 13 Glen Foster 2000-08-07 16:08:03 EDT
What happens if you boot the system *without* the Zip drive in it?
Comment 14 Bill Pemberton 2000-08-07 16:12:12 EDT
I realize that removing the zip is the obvious thing,  but this machine isn't
one that I can just tear apart on a whim.  That's why I was trying to see if the
zip bug is supposed to be squashed in the this beta -- if it's not, then that's
obviously the problem and I don't need to tear this beast apart.

Disabling the zip drive in the BIOS doesn't change the behaviour.
Comment 15 Bill Pemberton 2000-08-14 11:03:26 EDT
This is all fixed in RC1.
Comment 16 Bill Pemberton 2000-08-14 13:32:49 EDT
I'd like to clarify that the installer is what will now work (it correctly uses
the VGA server).  X itself will not, however, work with the #9 Revolution IV. 
If I chose to test it using the installer, I get a blank screen and I'm hung. 
If I skip the X configuration I can do the install fine, but I get the same hang
if I go through Xconfigurator.
Comment 17 Bill Nottingham 2000-08-15 11:33:46 EDT
Does Xconfigurator produce a working X display post-install?
Comment 18 Bill Pemberton 2000-08-15 12:33:12 EDT
Xconfigurator results in the same black screen as the installer when you get to
the 'Test X configuration' option.
Comment 19 Glen Foster 2000-08-16 18:38:07 EDT
This defect has been re-classified as SHOULD-FIX for Winston Gold-release
Comment 20 Aaron Brown 2000-08-31 16:22:38 EDT
This was a last minute fix that was fixed in an "RC" release.
Verfied that the problem is resolved, and GUI installation
works, as well as running X.

Note You need to log in before you can comment on or make changes to this bug.