Bug 1199500 - SELinux denials block deployment of FreeIPA domain controller role
Summary: SELinux denials block deployment of FreeIPA domain controller role
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 22
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException https://fedor...
Depends On:
Blocks: F22AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2015-03-06 14:05 UTC by Stephen Gallagher
Modified: 2015-03-10 02:59 UTC (History)
12 users (show)

Fixed In Version: selinux-policy-3.13.1-116.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-10 02:59:14 UTC
Type: Bug


Attachments (Terms of Use)
ipaserver-install.log (1.79 MB, text/plain)
2015-03-06 14:05 UTC, Stephen Gallagher
no flags Details
ipaclient-install.log (16.82 KB, text/plain)
2015-03-06 14:05 UTC, Stephen Gallagher
no flags Details
httpd error_log (3.06 KB, text/plain)
2015-03-06 14:06 UTC, Stephen Gallagher
no flags Details
audit2why -a (16.59 KB, text/plain)
2015-03-06 14:06 UTC, Stephen Gallagher
no flags Details

Description Stephen Gallagher 2015-03-06 14:05:23 UTC
Created attachment 998860 [details]
ipaserver-install.log

Description of problem:
It is impossible to deploy the Domain Controller role of Fedora Server due to SELinux denials during 'ipa-server-install'.

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-113.fc22.noarch
freeipa-server-4.1.3-2.fc22.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora Server Alpha RC3 or later with default settings. (Do not install the FreeIPA group in the anaconda installer due to an unrelated issue with RC3, just take the "Fedora Server" environment and nothing else).
2. Set the hostname of the machine with hostname-ctl to something sensible (not localhost[.localdomain]) with a hostname and domain part.
3. Create a dc.json file with the following contents:
cat dc.json << EOF
{
    "admin_password": "mypassword"
}
EOF

4. Run 'rolectl deploy --settings-file=dc.json domaincontroller'


Actual results:
The deployment will eventually return with an error and examination of the httpd error_log shows:

[Fri Mar 06 07:45:27.097721 2015] [auth_kerb:error] [pid 4617] [client 192.168.122.30:59340] Failed to initialize ccache for HTTP/freeipa.f22.sgallagh.rht@F22.SGALLAGH.RHT: Permission denied (13), referer: https://freeipa.f22.sgallagh.rht/ipa/xml
[Fri Mar 06 07:45:27.118844 2015] [auth_kerb:error] [pid 4617] [client 192.168.122.30:59340] gss_acquire_cred() failed: Unspecified GSS failure.  Minor code may provide more information (, Can't find client principal HTTP/freeipa.f22.sgallagh.rht@F22.SGALLAGH.RHT in cache collection), referer: https://freeipa.f22.sgallagh.rht/ipa/xml

audit2allow -a shows:

#============= abrt_dump_oops_t ==============
allow abrt_dump_oops_t passwd_file_t:file read;

#============= httpd_t ==============
allow httpd_t unconfined_service_t:key { read write view };

#============= kadmind_t ==============

#!!!! This avc can be allowed using the boolean 'nis_enabled'
allow kadmind_t unreserved_port_t:tcp_socket name_bind;




Expected results:
The deployment should complete successfully.

Additional info:

Comment 1 Stephen Gallagher 2015-03-06 14:05:46 UTC
Created attachment 998861 [details]
ipaclient-install.log

Comment 2 Stephen Gallagher 2015-03-06 14:06:14 UTC
Created attachment 998862 [details]
httpd error_log

Comment 3 Stephen Gallagher 2015-03-06 14:06:40 UTC
Created attachment 998863 [details]
audit2why -a

Comment 4 Fedora Blocker Bugs Application 2015-03-06 14:08:15 UTC
Proposed as a Blocker for 22-alpha by Fedora user sgallagh using the blocker tracking app because:

 "Unless explicitly specified otherwise, after system installation SELinux must be enabled and in enforcing mode."

"Release-blocking roles and the supported role configuration interfaces must meet the core functional Role Definition Requirements to the extent that supported roles can be successfully deployed, started, stopped, brought to a working configuration, and queried."

Comment 5 Petr Schindler 2015-03-06 20:12:01 UTC
Discussed at today's mini blocker review during Go/No-Go meeting [1].

This bug was rejected as Alpha blocker but will be considered as Freeze Exception - This bug can be resolved with update. If the update won't land before Alpha release we will add it to Common Bugs.

http://meetbot.fedoraproject.org/fedora-meeting-2/2015-03-06/

Comment 6 Fedora Update System 2015-03-06 22:09:04 UTC
selinux-policy-3.13.1-116.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/selinux-policy-3.13.1-116.fc22

Comment 7 Fedora Update System 2015-03-09 08:38:01 UTC
Package selinux-policy-3.13.1-116.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.13.1-116.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3508/selinux-policy-3.13.1-116.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-03-10 02:59:14 UTC
selinux-policy-3.13.1-116.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.