Bug 1199545 - mount.glusterfs uses /dev/stderr and fails if the device does not exist
Summary: mount.glusterfs uses /dev/stderr and fails if the device does not exist
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: scripts
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: nico-redhat-bugzilla
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1199577
TreeView+ depends on / blocked
 
Reported: 2015-03-06 15:16 UTC by nico-redhat-bugzilla
Modified: 2015-05-14 17:46 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1199577 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:29:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description nico-redhat-bugzilla 2015-03-06 15:16:00 UTC
Description of problem:

Instead of using standard >&2 implementation, mount.glusterfs writes to /dev/stderr.

This causes the mount to fail on current CentOS 7 systems with the following message:


Mar 06 16:13:44 entrance mount[1886]: /sbin/mount.glusterfs: line 13: /dev/stderr: No such device or address


Version-Release number of selected component (if applicable):

3.6.2

How reproducible:

always




Steps to Reproduce:
1. Add entry to /etc/fstab on CentOS 7 with glusterfs 3.6.2, reboot.
2. systemctl status



Actual results:

var-lib-one-datastores-100.mount - /var/lib/one/datastores/100
   Loaded: loaded (/etc/fstab)
   Active: failed (Result: exit-code) since Fri 2015-03-06 16:13:44 CET; 42s ago
    Where: /var/lib/one/datastores/100
     What: vmhost2-cluster1.place4.ungleich.ch:/cluster1
  Process: 1886 ExecMount=/bin/mount vmhost2-cluster1.place4.ungleich.ch:/cluster1 /var/lib/one/datastores/100 -t glusterfs -o defaults,_netdev,backupvolfile-server=vmhost1-cluster1.place4.ungleich.ch (code=exited, status=1/FAILURE)

Mar 06 16:13:40 entrance systemd[1]: Mounted /var/lib/one/datastores/100.
Mar 06 16:13:44 entrance mount[1886]: /sbin/mount.glusterfs: line 13: /dev/stderr: No such device or address
Mar 06 16:13:44 entrance systemd[1]: var-lib-one-datastores-100.mount mount process exited, code=exited status=1
Mar 06 16:13:44 entrance systemd[1]: Unit var-lib-one-datastores-100.mount entered failed state.
[16:14:27] entrance:~# 



Expected results:

glusterfs volumes mound

Additional info:

Preparing a patch for inclusion at the moment

Comment 1 Anand Avati 2015-03-06 15:29:58 UTC
REVIEW: http://review.gluster.org/9824 (Replace /dev/stderr with >&2 in mount scripts) posted (#1) for review on master by Nico Schottelius (nico-gluster-users@schottelius.org)

Comment 2 Niels de Vos 2015-03-06 16:27:50 UTC
I'll move this to the master branch, and will clone the bug to get the fix backported to release-3.6.

Comment 3 Anand Avati 2015-03-07 03:46:45 UTC
COMMIT: http://review.gluster.org/9824 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit adef0c8860f57c8137382d848244009e9a584497
Author: Nico Schottelius <nico@freiheit.schottelius.org>
Date:   Fri Mar 6 16:25:33 2015 +0100

    Replace /dev/stderr with >&2 in mount scripts
    
    /dev/stderr is not available on boot in CentOS 7 and thus
    mounting anything from /etc/fstab at boot time fails.
    
    Instead of using /dev/stderr, the standard error redirection ">&2" is being used.
    
    Change-Id: I15d07cd49e6b0392331047edb441925f48047b2b
    BUG: 1199545
    Signed-off-by: Nico Schottelius <nico@freiheit.schottelius.org>
    Reviewed-on: http://review.gluster.org/9824
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 4 Niels de Vos 2015-05-14 17:29:18 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 5 Niels de Vos 2015-05-14 17:35:53 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 6 Niels de Vos 2015-05-14 17:38:14 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 7 Niels de Vos 2015-05-14 17:46:25 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.