Bug 1199618 - Groups with yum not working
Summary: Groups with yum not working
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 21
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-06 18:32 UTC by anmol sethi
Modified: 2015-12-02 17:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 09:51:14 UTC
Type: Bug


Attachments (Terms of Use)

Description anmol sethi 2015-03-06 18:32:45 UTC
Description of problem: I cannot install groups with yum, i don't know why....


Version-Release number of selected component (if applicable): 21 Fedora Server


How reproducible: I tried to install text-based internet group and it wouldn't work. It kept saying this 

[aubble@aubserv ~]$ sudo yum groupinstall "Text-based Internet"
Loaded plugins: langpacks
Warning: Group text-internet does not have any packages to install.
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update

Don't know why.. So I ran that command and it marked it as installed, which I then ran the opposite command to unmark. I don't know if this has anything to do with this.

Steps to Reproduce:
1. 
2.
3.

Actual results: No group installs, it says:

[aubble@aubserv ~]$ sudo yum groupinstall "Text-based Internet"
[sudo] password for aubble: 
Loaded plugins: langpacks
Warning: Group text-internet does not have any packages to install.
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update


Expected results: The group should install..?


Additional info: The text-based internet group or editors isn't under installed either, only one group installed previously. I haven't tested any other groups other than text-based internet or editors.

[aubble@aubserv ~]$ sudo yum grouplist
Loaded plugins: langpacks
Available environment groups:
   Fedora Server
   Fedora Workstation
   Fedora Cloud Server
   KDE Plasma Workspaces
   Xfce Desktop
   LXDE Desktop
   Cinnamon Desktop
   LXQt Desktop
   MATE Desktop
   Sugar Desktop Environment
   Development and Creative Workstation
   Web Server
   Infrastructure Server
   Basic Desktop
   Minimal Install
Installed groups:
   Development Tools
Available Groups:
   3D Printing
   Administration Tools
   Audio Production
   Authoring and Publishing
   Books and Guides
   C Development Tools and Libraries
   Cloud Infrastructure
   Cloud Management Tools
   Cloud Server Tools
   Container Management
   D Development Tools and Libraries
   Design Suite
   Domain Membership
   Editors
   Educational Software
   Electronic Lab
   Engineering and Scientific
   Fedora Eclipse
   FreeIPA Server
   Games and Entertainment
   Headless Management
   LibreOffice
   MATE Applications
   MATE COMPIZ
   Medical Applications
   Milkymist
   Network Servers
   Office/Productivity
   RPM Development Tools
   Robotics
   Security Lab
   Sound and Video
   System Tools
   Text-based Internet
   Window Managers
Done

Comment 1 anmol sethi 2015-03-06 18:35:01 UTC
the command suggested by yum*

Comment 2 anmol sethi 2015-03-06 18:35:43 UTC
is what I ran and then the opposite of that removed it but while trying to figure it out I might have ran some wrong commands related to yum about marking, but I don't think it matters.

Comment 3 Fedora End Of Life 2015-11-04 13:17:06 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2015-12-02 09:51:16 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.