Bug 1199648 - [UX] dnf groupinstall claims that installed group does not exist
[UX] dnf groupinstall claims that installed group does not exist
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
: 1214164 1215438 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-06 16:11 EST by Petr Spacek
Modified: 2015-05-08 03:27 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.7-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-08 03:27:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Spacek 2015-03-06 16:11:55 EST
Description of problem:
"dnf groupinstall LibreOffice" claims that "Group 'LibreOffice' does not exist" even if "grouplist" shows it.


Version-Release number of selected component (if applicable):
dnf-0.6.4-1.fc21.noarch


How reproducible:
100 %


Steps to Reproduce:
1. $ dnf groupinstall LibreOffice
2. $ dnf groupinstall LibreOffice


Actual results:
# dnf grouplist
Using metadata from Wed Oct 18 02:10:32 2006
Available environment groups:
   Fedora Server
   Fedora Workstation
   Fedora Cloud Server
   KDE Plasma Workspaces
   Xfce Desktop
   LXDE Desktop
   LXQt Desktop
   Cinnamon Desktop
   MATE Desktop
   Sugar Desktop Environment
   Development and Creative Workstation
   Web Server
   Infrastructure Server
   Basic Desktop
   Minimal Install
Installed groups:
   LibreOffice
Available groups:
   3D Printing
   Administration Tools
   Audio Production
   Authoring and Publishing
   Books and Guides
   C Development Tools and Libraries
   Cloud Infrastructure
   Cloud Management Tools
   Cloud Server Tools
   Container Management
   D Development Tools and Libraries
   Design Suite
   Development Tools
   Domain Membership
   Fedora Eclipse
   Editors
   Educational Software
   Electronic Lab
   Engineering and Scientific
   FreeIPA Server
   Games and Entertainment
   Headless Management
   MATE Applications
   MATE Compiz
   Medical Applications
   Milkymist
   Network Servers
   Office/Productivity
   Robotics
   RPM Development Tools
   Security Lab
   Sound and Video
   System Tools
   Text-based Internet
   Window Managers

# dnf groupinstall LibreOffice
Using metadata from Wed Oct 18 02:10:32 2006
Warning: Group 'LibreOffice' does not exist.
Dependencies resolved.
Is this ok [y/N]: y
Complete!


Expected results:
It should skip groups which are already installed and print appropriate message.
Comment 1 Honza Silhan 2015-03-24 10:37:51 EDT
Thanks for the report. We'll fix it.
Comment 2 Honza Silhan 2015-04-07 08:46:27 EDT
PR: https://github.com/rpm-software-management/dnf/pull/249
Comment 3 Honza Silhan 2015-04-23 10:43:01 EDT
*** Bug 1214164 has been marked as a duplicate of this bug. ***
Comment 4 Honza Silhan 2015-04-28 06:59:27 EDT
*** Bug 1215438 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2015-05-02 09:49:32 EDT
dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
Comment 6 Fedora Update System 2015-05-03 13:24:30 EDT
Package dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.7-1.fc22 hawkey-0.5.5-1.fc22 dnf-1.0.0-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-7483/dnf-plugins-core-0.1.7-1.fc22,hawkey-0.5.5-1.fc22,dnf-1.0.0-1.fc22
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2015-05-08 03:27:08 EDT
dnf-plugins-core-0.1.7-1.fc22, hawkey-0.5.5-1.fc22, dnf-1.0.0-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.