Bug 119966 - nautilus hangs on start with FUTEX_WAIT
nautilus hangs on start with FUTEX_WAIT
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC2Blocker FC3Target
  Show dependency treegraph
 
Reported: 2004-04-04 05:30 EDT by Toni Willberg
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 09:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2004-04-04 05:30:52 EDT
Description of problem:

When starting Nautilus, it hangs with FUTEX_WAIT.

This has happened for me with all versions since the new GTK.

 nautilus-2.5.91-2
 glibc-2.3.3-20
 kernel-2.6.4-1.300
 gtk2-2.4.0-1

* strace output:
futex(0x9638658, FUTEX_WAIT, 0, NULL

* gdb backtrace:
#0  0x00ee37a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x001d57d0 in pthread_cond_wait@@GLIBC_2.3.2 () from
/lib/tls/libpthread.so.0
#2  0x00435af5 in giop_recv_buffer_get () from /usr/lib/libORBit-2.so.0
#3  0x004397b8 in ORBit_small_invoke_stub () from /usr/lib/libORBit-2.so.0
#4  0x00439680 in ORBit_small_invoke_stub_n () from
/usr/lib/libORBit-2.so.0
#5  0x0044d682 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#6  0x004054fc in Bonobo_ActivationContext_activateMatchingFull ()
from /usr/lib/libbonobo-activation.so.4
#7  0x00410584 in Bonobo_ActivationContext__iinterface () from
/usr/lib/libbonobo-activation.so.4
Comment 1 Alexander Larsson 2004-04-06 11:59:02 EDT
Any chance you could install the debuginfo package for libbonobo and
ORBit2 and get a new backtrace?
Comment 2 Toni Willberg 2004-05-07 02:57:35 EDT
Seems I've forgotten to debug this. Will do after couple of weeks.

If someone else is seeing the same problem, and have time to debug it
sooner, please do so.
Comment 3 Alexander Larsson 2004-09-06 09:01:36 EDT
Is this still happening?
Comment 4 Toni Willberg 2004-09-06 09:57:08 EDT
Doesn't happen with my current installations, and I don't have that
old installation available anymore to test with.

I'll close this as WORKSFORME. Thanks for the reminder. :)

Note You need to log in before you can comment on or make changes to this bug.