Bug 1199712 - [abrt] gnome-contacts: _gtk_settings_get_style_cascade(): gnome-contacts-search-provider killed by SIGSEGV
Summary: [abrt] gnome-contacts: _gtk_settings_get_style_cascade(): gnome-contacts-sear...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-contacts
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elad Alfassa
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f19ccffd6d19db870a64c355990...
: 1231527 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-07 09:45 UTC by miguel rodriguez
Modified: 2015-07-10 19:13 UTC (History)
16 users (show)

Fixed In Version: gnome-contacts-3.16.2-4.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-10 19:13:47 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (38.09 KB, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: cgroup (190 bytes, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: core_backtrace (27.19 KB, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: dso_list (19.32 KB, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: environ (909 bytes, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: limits (1.29 KB, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: maps (92.71 KB, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: open_fds (964 bytes, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: proc_pid_status (963 bytes, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details
File: var_log_messages (2.08 KB, text/plain)
2015-03-07 09:45 UTC, miguel rodriguez
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 750724 None None None Never

Description miguel rodriguez 2015-03-07 09:45:22 UTC
Description of problem:
I no have yet any account in this app, but i have evolution works fine with 2 accounts. The problem appears radomly in top of clock of gnome-shell, appears pop-up message about fails this app.

Version-Release number of selected component:
gnome-contacts-3.15.90-1.fc22

Additional info:
reporter:       libreport-2.4.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-contacts-search-provider
crash_function: _gtk_settings_get_style_cascade
executable:     /usr/libexec/gnome-contacts-search-provider
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 _gtk_settings_get_style_cascade at /lib64/libgtk-3.so.0
 #1 gtk_style_context_init at /lib64/libgtk-3.so.0
 #2 g_type_create_instance at /lib64/libgobject-2.0.so.0
 #3 g_object_new_internal at /lib64/libgobject-2.0.so.0
 #6 _gtk_style_new_for_path at /lib64/libgtk-3.so.0
 #7 gtk_style_new at /lib64/libgtk-3.so.0
 #8 gtk_widget_get_default_style at /lib64/libgtk-3.so.0
 #9 gtk_widget_init at /lib64/libgtk-3.so.0
 #10 g_type_create_instance at /lib64/libgobject-2.0.so.0
 #11 g_object_new_internal at /lib64/libgobject-2.0.so.0

Comment 1 miguel rodriguez 2015-03-07 09:45:26 UTC
Created attachment 999121 [details]
File: backtrace

Comment 2 miguel rodriguez 2015-03-07 09:45:27 UTC
Created attachment 999122 [details]
File: cgroup

Comment 3 miguel rodriguez 2015-03-07 09:45:29 UTC
Created attachment 999123 [details]
File: core_backtrace

Comment 4 miguel rodriguez 2015-03-07 09:45:30 UTC
Created attachment 999124 [details]
File: dso_list

Comment 5 miguel rodriguez 2015-03-07 09:45:32 UTC
Created attachment 999125 [details]
File: environ

Comment 6 miguel rodriguez 2015-03-07 09:45:33 UTC
Created attachment 999126 [details]
File: limits

Comment 7 miguel rodriguez 2015-03-07 09:45:35 UTC
Created attachment 999127 [details]
File: maps

Comment 8 miguel rodriguez 2015-03-07 09:45:36 UTC
Created attachment 999128 [details]
File: open_fds

Comment 9 miguel rodriguez 2015-03-07 09:45:37 UTC
Created attachment 999129 [details]
File: proc_pid_status

Comment 10 miguel rodriguez 2015-03-07 09:45:38 UTC
Created attachment 999130 [details]
File: var_log_messages

Comment 11 lennart_reuther 2015-05-16 09:26:09 UTC
Another user experienced a similar problem:

restart after dnf upgrade, i guess.

reporter:       libreport-2.5.1
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-contacts-search-provider
crash_function: _gtk_settings_get_style_cascade
executable:     /usr/libexec/gnome-contacts-search-provider
global_pid:     8443
kernel:         4.0.2-300.fc22.x86_64
package:        gnome-contacts-3.16.2-1.fc22
reason:         gnome-contacts-search-provider killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Matthias Clasen 2015-06-10 16:04:20 UTC
After discussing the stacktrace and the circumstances a bit with Benjamin, we've concluded that this is a case where we end up calling GTK+ api without gtk_init() first. The search provider should probably not try to show dialogs, but if it does, it needs to call gtk_init...

Comment 13 Matthias Clasen 2015-06-10 16:43:15 UTC
Filed upstream: https://bugzilla.gnome.org/show_bug.cgi?id=750724

Comment 14 Fedora Update System 2015-06-11 20:25:45 UTC
gnome-contacts-3.16.2-3.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-contacts-3.16.2-3.fc22

Comment 15 Michael Catanzaro 2015-06-11 21:09:50 UTC
FYI: there are actually two different search provider crashes fixed upstream since 3.16.2, and we only have a patch for one of them in 3.16.2-3.

Comment 16 Matthias Clasen 2015-06-12 11:11:00 UTC
we actually have them both; I didn't do that in the cleanest way, but the patch I applied has both changes.

Comment 17 Fedora Update System 2015-06-13 06:38:15 UTC
Package gnome-contacts-3.16.2-3.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-contacts-3.16.2-3.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9901/gnome-contacts-3.16.2-3.fc22
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2015-06-21 00:08:35 UTC
gnome-contacts-3.16.2-3.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Michael Catanzaro 2015-06-25 12:42:57 UTC
642 reports of this crash with 3.16.2-3.fc22 in FAF. :(

Comment 20 Michael Catanzaro 2015-06-25 12:43:39 UTC
*** Bug 1231527 has been marked as a duplicate of this bug. ***

Comment 21 Milan Crha 2015-06-29 15:38:51 UTC
(In reply to Michael Catanzaro from comment #19)
> 642 reports of this crash with 3.16.2-3.fc22 in FAF. :(

The update had patch added, but not applied. Somebody should correct it.

Comment 22 Michael Catanzaro 2015-06-30 04:06:59 UTC
(In reply to Milan Crha from comment #21)
> The update had patch added, but not applied. Somebody should correct it.

That would help, thanks.

Comment 23 Fedora Update System 2015-06-30 04:21:47 UTC
gnome-contacts-3.16.2-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/gnome-contacts-3.16.2-4.fc22

Comment 24 Fedora Update System 2015-06-30 20:20:48 UTC
Package gnome-contacts-3.16.2-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-contacts-3.16.2-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10972/gnome-contacts-3.16.2-4.fc22
then log in and leave karma (feedback).

Comment 25 Fedora Update System 2015-07-10 19:13:47 UTC
gnome-contacts-3.16.2-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.