Bug 1199719 - Cannot resize the desktop icons (gnome3 desktop with nautilus) to a smaller size in F122/Alpha/TC8
Summary: Cannot resize the desktop icons (gnome3 desktop with nautilus) to a smaller s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-07 12:41 UTC by Joachim Backes
Modified: 2015-03-25 13:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-25 13:34:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Backes 2015-03-07 12:41:11 UTC
Description of problem:
HAving running F22/Allpha/TC8/gnome3 with nautilus as file manager. If I try to resize the desktop icons to a smaller size (select an icon with left mouse button, then open the context menu with right mouse button and say: "resize icon"). Trying to resize by mouse button 1 to a smaller size fails (the selection rectangle's size will not change).

Additionally, it seems the icons are rather huge on the desktop (the sizes in F21 are smaller!). I will attach a screen photo

Version-Release number of selected component (if applicable):
nautilus-3.15.90-1.fc22.x86_64

How reproducible:
always

Steps to Reproduce:
1.see description
2.
3.

Actual results:
no resizing possible

Expected results:
resizing will be performed

Additional info:

Comment 1 Matthias Clasen 2015-03-09 20:32:00 UTC
Resizing works fine here, also with 3.15.90. 
The oversize icons are a known issue that will be fixed before 3.16

Comment 2 Joachim Backes 2015-03-10 06:30:36 UTC
1. Perhaps it helps that I'm using my complete desktop well grown in F21, where the resizing works well.
2. Increasing the icon size works well, but not making smaller

Comment 3 Joachim Backes 2015-03-10 06:41:07 UTC
Creating a new user shows the same problems

Comment 4 Conley Moorhous 2015-03-10 14:19:44 UTC
Resizing icons works for me (using a new install of F22). Try renaming your Gnome config files to see if it will work then. Start with these files:

~/.config/dconf/
~/.config/nautilus/

If resizing still doesn't work, rename these as well:

~/.gnome
~/.gconf
~/.local/share/nautilus
~/.local/share/gnome-shell/

I think one (or some) of those should be relevant. You'll have to turn desktop icons back on (via gnome-tweak-tool) before you can test resizing.

Comment 5 Conley Moorhous 2015-03-10 14:21:11 UTC
Oh, I just realized creating a new user would do just that.. Hmm. Have you updated to 3.15.91? Does the issue still persist with the latest updates?

Comment 6 Joachim Backes 2015-03-10 14:51:43 UTC
(In reply to Conley Moorhous from comment #5)
> Oh, I just realized creating a new user would do just that.. Hmm. Have you
> updated to 3.15.91? Does the issue still persist with the latest updates?

If you tell me,how?

Comment 7 Conley Moorhous 2015-03-10 15:47:08 UTC
(In reply to Joachim Backes from comment #6)
> (In reply to Conley Moorhous from comment #5)
> > Oh, I just realized creating a new user would do just that.. Hmm. Have you
> > updated to 3.15.91? Does the issue still persist with the latest updates?
> 
> If you tell me,how?

dnf is the new tool for upgrading your system to the latest packages. If you have sudo set up, just type

sudo dnf upgrade

into a terminal. Otherwise,

su

to switch to the administrator account and then

dnf upgrade

To check the version of gnome-shell that you currently have, type

sudo dnf info gnome-shell

Or go to Gnome Control Center (Settings) -> Details.

Comment 8 Joachim Backes 2015-03-10 17:29:21 UTC
sudo dnf upgrade
Using metadata from Tue Mar 10 10:45:12 2015
Dependencies resolved.
Nothing to do.
backes@eule [~/Desktop]: sudo dnf upgrade gnome-shell
Using metadata from Tue Mar 10 10:45:12 2015
Dependencies resolved.
Nothing to do.

So seems not available found in any f22 repo :-(

Comment 9 Joachim Backes 2015-03-13 15:47:28 UTC
I checked now the same with 3.15.91, but i's not possible to make the icons size arbitrarily smaller.

Comment 10 Joachim Backes 2015-03-25 11:58:01 UTC
(In reply to Joachim Backes from comment #2)
> 1. Perhaps it helps that I'm using my complete desktop well grown in F21,
> where the resizing works well.
> 2. Increasing the icon size works well, but not making smaller

Still with gdm-3.16.0.1-1.fc22.x86_64 making icons smaller does not work.

Comment 11 Joachim Backes 2015-03-25 13:34:38 UTC
(In reply to Joachim Backes from comment #10)
> (In reply to Joachim Backes from comment #2)
> > 1. Perhaps it helps that I'm using my complete desktop well grown in F21,
> > where the resizing works well.
> > 2. Increasing the icon size works well, but not making smaller
> 
> Still with gdm-3.16.0.1-1.fc22.x86_64 making icons smaller does not work.

Solved by configuring Nautilus using the files menue in the gnome dashboard appearing if opening some nautilus window on the desktop.


Note You need to log in before you can comment on or make changes to this bug.