Bug 1199747 - [abrt] WARNING: CPU: 0 PID: 684 at drivers/gpu/drm/i915/i915_gem.c:4284 i915_gem_object_unpin_fence+0x75/0xa0 [i915]() [i915]
Summary: [abrt] WARNING: CPU: 0 PID: 684 at drivers/gpu/drm/i915/i915_gem.c:4284 i915_...
Keywords:
Status: CLOSED DUPLICATE of bug 1195975
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:b77b7849bc6d2d0d1598fbf8ed7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-07 21:00 UTC by John
Modified: 2015-05-27 16:12 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-27 16:12:50 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: dmesg (108.94 KB, text/plain)
2015-03-07 21:00 UTC, John
no flags Details
journalctl -b-1 (788.29 KB, text/plain)
2015-03-09 05:54 UTC, Conley Moorhous
no flags Details

Description John 2015-03-07 21:00:51 UTC
Additional info:
reporter:       libreport-2.4.0
WARNING: CPU: 0 PID: 684 at drivers/gpu/drm/i915/i915_gem.c:4284 i915_gem_object_unpin_fence+0x75/0xa0 [i915]()
WARN_ON(dev_priv->fence_regs[obj->fence_reg].pin_count <= 0)
Modules linked in: bnep bluetooth xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ccm ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw vfat fat arc4 intel_rapl iosf_mbi rt2800pci rt2800mmio rt2800lib rt2x00pci uvcvideo rt2x00mmio rt2x00lib x86_pkg_temp_thermal coretemp kvm_intel snd_hda_codec_hdmi snd_hda_codec_realtek mac80211 videobuf2_vmalloc videobuf2_core snd_hda_codec_generic cfg80211 videobuf2_memops snd_hda_intel
 snd_hda_controller snd_hda_codec asus_nb_wmi v4l2_common kvm videodev asus_wmi eeprom_93cx6 snd_hwdep sparse_keymap crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel crc_ccitt snd_seq rfkill media iTCO_wdt iTCO_vendor_support snd_seq_device snd_pcm i2c_i801 mei_me shpchp serio_raw snd_timer snd wmi lpc_ich mfd_core mei soundcore nfsd auth_rpcgss nfs_acl lockd grace sunrpc i915 i2c_algo_bit drm_kms_helper drm alx ata_generic pata_acpi mdio video
CPU: 0 PID: 684 Comm: systemd-logind Not tainted 4.0.0-0.rc2.git0.1.fc22.x86_64 #1
Hardware name: ASUSTeK COMPUTER INC. X502CA/X502CA, BIOS X502CA.207 02/21/2013
 0000000000000000 00000000b0be6df8 ffff8800bbf4b6f8 ffffffff81780388
 0000000000000000 ffff8800bbf4b750 ffff8800bbf4b738 ffffffff8109c83a
 ffff8800bbf4b798 ffff88003eaf0000 ffff880114236000 ffffffffa0181f80
Call Trace:
 [<ffffffff81780388>] dump_stack+0x45/0x57
 [<ffffffff8109c83a>] warn_slowpath_common+0x8a/0xc0
 [<ffffffff8109c8c5>] warn_slowpath_fmt+0x55/0x70
 [<ffffffffa00f2905>] i915_gem_object_unpin_fence+0x75/0xa0 [i915]
 [<ffffffffa012e545>] intel_unpin_fb_obj+0x25/0x60 [i915]
 [<ffffffffa013a91d>] intel_cleanup_plane_fb+0x3d/0x80 [i915]
 [<ffffffffa00a38be>] drm_plane_helper_commit+0x1fe/0x300 [drm_kms_helper]
 [<ffffffffa00a3a5a>] drm_plane_helper_update+0x9a/0xf0 [drm_kms_helper]
 [<ffffffffa013a426>] intel_crtc_set_config+0xdb6/0x1010 [i915]
 [<ffffffffa0047056>] drm_mode_set_config_internal+0x66/0x100 [drm]
 [<ffffffffa00ac738>] restore_fbdev_mode+0xc8/0xf0 [drm_kms_helper]
 [<ffffffffa00ae789>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x80 [drm_kms_helper]
 [<ffffffffa00ae802>] drm_fb_helper_set_par+0x22/0x50 [drm_kms_helper]
 [<ffffffffa0149b4a>] intel_fbdev_set_par+0x1a/0x60 [i915]
 [<ffffffff814182f6>] fb_set_var+0x236/0x480
 [<ffffffff811bd034>] ? shmem_undo_range+0x494/0x750
 [<ffffffff810c9490>] ? wake_up_state+0x20/0x20
 [<ffffffff810dec98>] ? __wake_up+0x48/0x60
 [<ffffffff8140ddfc>] fbcon_blank+0x34c/0x390
 [<ffffffff81494cfa>] do_unblank_screen+0xda/0x1d0
 [<ffffffff8148995b>] vt_ioctl+0x57b/0x1430
 [<ffffffff8147c621>] tty_ioctl+0x3f1/0xc30
 [<ffffffff811d8832>] ? unmap_region+0xe2/0x130
 [<ffffffff812350f6>] do_vfs_ioctl+0x2c6/0x4d0
 [<ffffffff811db1ed>] ? do_munmap+0x35d/0x4a0
 [<ffffffff81235381>] SyS_ioctl+0x81/0xa0
 [<ffffffff817867a9>] system_call_fastpath+0x12/0x17

Comment 1 John 2015-03-07 21:00:57 UTC
Created attachment 999216 [details]
File: dmesg

Comment 2 Conley Moorhous 2015-03-09 05:52:24 UTC
I get the same thing (my kernel bug is reported to be on line 4257 rather than 4256, not important I assume). When this bug happens, the computer completely locks up (e.g., caps lock button does not change indicator light). It seems to happen more often when I am switching from console VTs to VT1, with GDM. I think it has occurred during normal usage as well, though.

Comment 3 Conley Moorhous 2015-03-09 05:54:47 UTC
Created attachment 999436 [details]
journalctl -b-1

This is journalctl output from the entire boot. See lines 5161-5254

Comment 4 Matthias Clasen 2015-03-10 13:35:23 UTC
this is happening on my machine too, with

kernel-4.0.0-0.rc2.git0.1.fc22.x86_64
xorg-x11-drv-intel-2.99.917-6.20150211.fc22.x86_64

Comment 5 Ting-Wei Lan 2015-04-18 18:23:58 UTC
I no longer get this problem on my machine with kernel-4.0.0-1.fc22.x86_64.

Comment 6 Adam Jackson 2015-05-27 16:12:50 UTC

*** This bug has been marked as a duplicate of bug 1195975 ***


Note You need to log in before you can comment on or make changes to this bug.