Bug 119983 - Net::DNS (perl) 0.48 released
Net::DNS (perl) 0.48 released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Net-DNS (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
http://www.net-dns.org/docs/Changes.html
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-04-04 12:58 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 20:02:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-04-04 12:58:53 EDT
Description of problem:
Net::DNS (perl) 0.47 is released, while Fedora Development is hanging 
around 0.31, more you can get from the changelog of Net::DNS.

Version-Release number of selected component (if applicable):
perl-Net-DNS-0.31-3.2

Actual results:
Upgrade to 0.47 is possible using a little fix (see at the bottom).

Expected results:
Please upgrade to 0.47

Additional info:
--- perl-Net-DNS.spec       2004-04-04 18:49:57.000000000 +0200
+++ perl-Net-DNS.spec.rsc   2004-04-04 18:59:14.000000000 +0200
@@ -1,8 +1,8 @@
 %define _use_internal_dependency_generator 0

 Name: perl-Net-DNS
-Version: 0.31
-Release: 3.2
+Version: 0.47
+Release: 1
 Summary: Net-DNS Perl module
 License: distributable
 Group: Development/Libraries
@@ -10,6 +10,7 @@
 BuildRoot: %{_tmppath}/%{name}-root
 BuildRequires: perl >= 0:5.00503
 Source0: Net-DNS-%{version}.tar.gz
+Source1: Net-DNS-filter-depends.sh
 BuildArch: noarch
 BuildRequires: perl-Digest-HMAC

@@ -22,6 +23,10 @@
 packet and its various sections. See RFC 1035 or DNS and BIND (Albitz
 & Liu) for details.

+# Provide perl-specific find-{provides,requires}.
+%define __find_provides /usr/lib/rpm/find-provides.perl
+%define __find_requires %{SOURCE1}
+
 %prep
 %setup -q -n Net-DNS-%{version}

--- snipp Net-DNS-filter-depends.sh ---
#!/bin/sh

/usr/lib/rpm/find-requires.perl $* | grep -v Win32
--- snapp Net-DNS-filter-depends.sh ---
Comment 1 Robert Scheck 2004-05-01 10:32:59 EDT
Well, one part you fixed now, but you didn't solve the complete issue
:-( and the part you fixed, was another bug ;-)

Here's the diff from the latest perl-Net-DNS from the Fedora 
Development to 0.47:

--- perl-Net-DNS.spec           2004-04-30 01:31:47.000000000 +0200
+++ perl-Net-DNS.spec.rsc       2004-05-01 16:38:16.000000000 +0200
@@ -1,15 +1,15 @@
 %define _use_internal_dependency_generator 0

 Name: perl-Net-DNS
-Version: 0.45
-Release: 3
+Version: 0.47
+Release: 1
 Summary: Net-DNS Perl module
 License: distributable
 Group: Development/Libraries
-URL: http://search.cpan.org/search?mode=module&query=Net%3a%3aDNS
+URL: http://www.net-dns.org/
 BuildRoot: %{_tmppath}/%{name}-root
 BuildRequires: perl >= 0:5.00503
-Source0: Net-DNS-%{version}.tar.gz
+Source0: http://www.net-dns.org/download/Net-DNS-%{version}.tar.gz
 Source1: filter-depends.sh
 BuildRequires: perl-Digest-HMAC
Comment 2 Robert Scheck 2004-08-23 12:51:04 EDT
Net::DNS 0.48 (perl) is available since August 12, 2004, requesting 
update to 0.48. Update between 0.47 and 0.48 (after applying my changes
is only a simple version number change in the spec file.

Note You need to log in before you can comment on or make changes to this bug.