Bug 119987 - initscripts code cleanup
Summary: initscripts code cleanup
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-04-04 17:48 UTC by Steve Grubb
Modified: 2014-03-17 02:43 UTC (History)
1 user (show)

Fixed In Version: 7,.51-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 16:28:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug fix patch (5.70 KB, patch)
2004-04-04 17:49 UTC, Steve Grubb
no flags Details | Diff

Description Steve Grubb 2004-04-04 17:48:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
During code review found: leaked memory, not properly checking file
descriptors before using them, a call to poll that returned -1 because
of EINTR is being processed as if it were a valid return from poll,
return code from forkCommand not being used at all, testing of device
file susceptible to races in usernetctl, and userctl tests were
unneccessarily case sensitive.

Version-Release number of selected component (if applicable):
initscripts-7.48

How reproducible:
Always

Steps to Reproduce:
Found by code inpection

Additional info:

I have a patch that I will attach. Please consider applying it before
fedora core 2 final.

Comment 1 Steve Grubb 2004-04-04 17:49:52 UTC
Created attachment 99099 [details]
Bug fix patch

Please consider applying this.

Comment 2 Bill Nottingham 2004-05-04 16:28:21 UTC
Someone actually looked through process.c. Yikes, my condolances (it
should really be taken out and shot.)

Some of the forkCommand stuff is only correct due to the fact that
it's only called with certain arguments; but that's ok.

Thanks for looking at this... will be in 7.51-1.



Note You need to log in before you can comment on or make changes to this bug.