Bug 119990 - logout or change to console turns screen black
logout or change to console turns screen black
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Depends On:
  Show dependency treegraph
Reported: 2004-04-04 16:12 EDT by Parrish Myers
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.5-1.358
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-23 02:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Parrish Myers 2004-04-04 16:12:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; 
Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
I have to boot with 'nogui' set, otherwise the same problem 
happens... only half way through the boot process.

When tring to logout of an X session, the screen goes black and never 
comes back.  The same thing happens if I try to switch to a console 
prompt via ctrl-alt-f1.  The screen goes black.

I also can't shut down properly either... I select shutdown from the 
logout menu and the screen still goes black and it never shuts down.

I have not been able to shut the computer down properly since I 
installed FC2 test2.  I always have to hold the power button.  Isn't 
this eventually going to corrupt the disk?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. login via gdm
2. logout
& wham!
1. ctrl-alt-f1
& wham!

Additional info:

hp pavilion ze4315us laptop with 
ATI Radeon Mobility U1 (IGP 320M)
vesa driver
Comment 1 Parrish Myers 2004-04-11 13:09:11 EDT
It started working again with kernel version:

but, in the last update... the only thing updated was some policy
stuff and this version of the kernel:

and it stoped working.  What is different between these two kernel
Comment 2 David Fraser 2004-04-15 08:17:40 EDT
I have had a similar problem with my machine, it is impossible to
switch away from X, the display gets garbled/mangled, never returns to
text mode.
By restarting X (via ssh) the display can be restored to a graphical
display, but never to a text display.
This happens in both the vesa driver and the nv driver.
I have reproduced it with kernel-2.6.3- and kernel-2.6.5-1.322
Comment 3 David Garcia 2004-04-22 20:42:29 EDT
Not only do I have the shut down problem (I'm running kernel-2.6.5-
1.332), but I also go black on bootup unless I have the "nogui" on.  
I thought this latter Bug was fixed?  (I have a ThinkPad T41p with a 
ATI Mobility FIREGL T2 card.  Hopes this helps.)
Comment 4 Holger Eilhard 2004-04-29 05:52:23 EDT
I have the same problem using test3 and am also using a T41p.
Comment 5 David Fraser 2004-05-03 06:45:39 EDT
This should be high priority, as it makes me have to reboot the system
Comment 6 Holger Eilhard 2004-05-05 08:14:50 EDT
Seems to work for me with the most recent kernel (2.6.5-1.349)!
Comment 7 Mike A. Harris 2004-05-05 11:33:03 EDT
This does not sound like an X11 problem, but rather it sounds like
a kernel problem if changing the kernel makes things work/not work.

Parrish) Can you confirm wether updating your system to current
rawhide, including the kernel and all other components, and rebooting
into the new kernel works or not for you?

Setting bug to MODIFIED state pending kernel testing.  If the problem
still persists after testing with a fully updated system, please
change the bug state back to "ASSIGNED".  If the problem is fixed
for you, please close as "RAWHIDE".

Thanks in advance.
Comment 8 Parrish Myers 2004-05-05 17:45:29 EDT
Ahhhhh!  I'm right in the middle of a move (and I am tring to fix the
house up so it sells quickly)... can this wait until Sunday?
Comment 9 Mike A. Harris 2004-05-05 18:31:22 EDT
Whenever you have time to test it is fine.  Just update the status
to RAWHIDE or ASSIGNED as I mentioned above once you've confirmed
wether it is fixed or still present, and we can continue to track
the issue if it is still there.

You may also want to review the Fedora Core 2 schedule at:

If the above is accurate, our final development freeze is on
Friday May 7th roughly at noon EST.  Engineering time is rather
tight currently due to proximity to the final freeze, so if the
problem is still present after testing, it'll probably have to
wait for an FC2 update or FC3 development at this point (even if
discovered right away).

Good luck on your move, and your new place!  Moving is always a
lot of work.  Hopefully once you're settled in and get back up
and running, you'll get a welcome surprise of a working X desktop.

Take care,
Comment 10 Holger Eilhard 2004-05-06 06:09:58 EDT
2.6.5-1.350 still works ;-)
Comment 11 Parrish Myers 2004-05-23 02:29:45 EDT
Thank's for the time.  I have installed FC2 and subsequently kernel
2.6.5-1.358.  And yes the bug is fixed.  Thanks.  I am setting the bug
to resolved as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.