Bug 1199903 - Cannot delete monitor (also pool and member), when deleting scalable application with openshift-routing-daemon
Summary: Cannot delete monitor (also pool and member), when deleting scalable applicat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Unknown
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: ---
Assignee: chris alfonso
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-09 08:28 UTC by Kenjiro Nakayama
Modified: 2019-05-20 11:35 UTC (History)
10 users (show)

Fixed In Version: rubygem-openshift-origin-routing-daemon-0.22.2.2-1
Doc Type: Bug Fix
Doc Text:
Previously if the routing daemon was configured for use with F5 BIG-IP LTM® and was configured to create monitors or assign an existing monitor to new pools, errors occurred while deleting a scalable application when the process attempted to delete the associated monitor. This was due to a bug in the routing daemon. This bug fix updates the routing daemon to address these issues, and as a result these errors no longer occur. Additionally, the routing daemon now reports error messages from F5 in more situations rather than generic failure messages.
Clone Of:
Environment:
Last Closed: 2015-04-06 17:06:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1199901 0 high CLOSED Cannot create monitor (also pool/member) when creating scalable application with openshift-routing-daemon started 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2015:0779 0 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.2.5 bug fix and enhancement update 2015-04-06 21:05:45 UTC

Internal Links: 1199901

Description Kenjiro Nakayama 2015-03-09 08:28:34 UTC
Version-Release number of selected component (if applicable):
===

- OSE 2.2

How reproducible
===

1. Set up /etc/openshift/routing-daemon.conf with F5 BIG-IP and routing daemon
2. Fix bz1199901 by yourself.
3. Create application with -s option(Enable scaling)
4. Delete application
5. You will get following message

Actual results
===
~~~
I, [2015-03-04T10:31:57.679614 #30014]  INFO -- : Deleting pool: xxxxxxxxxxxxxxxxx
W, [2015-03-04T10:31:57.876950 #30014]  WARN -- : Got an exception: undefined local variable or method `monitor_path' for #<OpenShift::RoutingDaemon:0x000000020a3e60>
D, [2015-03-04T10:31:57.877065 #30014] DEBUG -- : Backtrace:
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-routing-daemon-0.22.1.2/lib/openshift/routing/daemon.rb:329:in `delete_application'
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-routing-daemon-0.22.1.2/lib/openshift/routing/daemon.rb:252:in `handle'
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-routing-daemon-0.22.1.2/lib/openshift/routing/daemon.rb:226:in `listen'
/etc/init.d/openshift-routing-daemon:94:in `block (2 levels) in <main>'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/application.rb:215:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/application.rb:215:in `block in start_proc'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/daemonize.rb:192:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/daemonize.rb:192:in `call_as_daemon'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/application.rb:219:in `start_proc'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/application.rb:255:in `start'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/controller.rb:69:in `run'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons.rb:188:in `block in run_proc'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/cmdline.rb:105:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons/cmdline.rb:105:in `catch_exceptions'
/opt/rh/ruby193/root/usr/share/gems/gems/daemons-1.0.10/lib/daemons.rb:187:in `run_proc'
/etc/init.d/openshift-routing-daemon:93:in `block in <main>'
/etc/init.d/openshift-routing-daemon:37:in `block (2 levels) in locked'
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-common-1.28.3.0/lib/openshift-origin-common/utils/path_utils.rb:93:in `block in flock'
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-common-1.28.3.0/lib/openshift-origin-common/utils/path_utils.rb:88:in `open'
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-common-1.28.3.0/lib/openshift-origin-common/utils/path_utils.rb:88:in `flock'
/etc/init.d/openshift-routing-daemon:36:in `block in locked'
/opt/rh/ruby193/root/usr/share/ruby/timeout.rb:69:in `timeout'
/etc/init.d/openshift-routing-daemon:35:in `locked'
/etc/init.d/openshift-routing-daemon:80:in `<main>'
~~~

Expected results:
===
- Delete application without any error.

Comment 4 chris alfonso 2015-03-11 19:10:42 UTC
PR opened upstream for origin-server https://github.com/openshift/origin-server/pull/6092

Comment 8 Johnny Liu 2015-03-17 10:57:16 UTC
Verified this bug with rubygem-openshift-origin-routing-daemon-0.22.2.2-1.el6op.noarch, and PASS.

After upgrade it to rubygem-openshift-origin-routing-daemon-0.22.2.2-1.el6op.noarch, the error disappeared.

Comment 10 errata-xmlrpc 2015-04-06 17:06:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0779.html


Note You need to log in before you can comment on or make changes to this bug.