Bug 1199923 - Make sure both keystone and the tuskar GUI show the correct horizon URL
Summary: Make sure both keystone and the tuskar GUI show the correct horizon URL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-09 09:48 UTC by Udi
Modified: 2015-08-05 13:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2015-03-09 09:48:05 UTC
Description of problem:
After a deployment with tripleo, the horizon url in 'keystone endpoint-list' contains a redundant colon and no "/dashboard" path. The GUI does some string manipulation to cover for the problem but it's not good enough. We would like the keystone catalog to be generated correctly and remove the need for cosmetic fixes on  the part of the GUI.


How reproducible:
100%


Additional info:
Old bug for OSP 6 is here: https://bugzilla.redhat.com/show_bug.cgi?id=1179821

Comment 3 Jiri Tomasek 2015-03-11 09:44:43 UTC
Upstream patch is here: https://review.openstack.org/163339

We also need to make sure, that "dd00676 Add webroot to overcloud dashboard url" commit is reverted or better not used at all in 7.0 downstream branch.

Comment 6 Udi 2015-06-29 16:47:01 UTC
Verified. Horizon is not defined as an endpoint in keystone any more, and doesn't appear in the catalog. It seems like the right way this way, so this bug is not needed.

Comment 8 errata-xmlrpc 2015-08-05 13:50:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.