Bug 1199972 - perl-Gtk3-0.019-1.fc23 FTBFS: Can't use string ("320") as an ARRAY ref while "strict refs" in use at t/overrides.t line 235.
Summary: perl-Gtk3-0.019-1.fc23 FTBFS: Can't use string ("320") as an ARRAY ref while ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Gtk3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
: 1239613 (view as bug list)
Depends On:
Blocks: 1231897 F23FTBFS
TreeView+ depends on / blocked
 
Reported: 2015-03-09 12:13 UTC by Petr Pisar
Modified: 2015-07-13 13:21 UTC (History)
4 users (show)

Fixed In Version: perl-Gtk3-0.022-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-13 13:18:03 UTC
Type: Bug


Attachments (Terms of Use)
Fix the position error (538 bytes, patch)
2015-05-06 14:40 UTC, Petr Šabata
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
CPAN 105835 0 None None None Never

Description Petr Pisar 2015-03-09 12:13:34 UTC
perl-Gtk3-0.019-1.fc23 fails to build in F23 because a test fails:

t/floating-refs.t .............. ok
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
GLib-GObject-WARNING **: The property GtkColorButton:color is deprecated and shouldn't be used anymore. It will be removed in a future version. at /usr/lib64/perl5/vendor_perl/Glib/Object/Introspection.pm line 58.
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.
GLib-GObject-WARNING **: The property GtkButton:use-stock is deprecated and shouldn't be used anymore. It will be removed in a future version. at /builddir/build/BUILD/Gtk3-0.019/blib/lib/Gtk3.pm line 702.
GLib-GObject-WARNING **: The property GtkSettings:gtk-button-images is deprecated and shouldn't be used anymore. It will be removed in a future version. at /builddir/build/BUILD/Gtk3-0.019/blib/lib/Gtk3.pm line 702.
*** menu position callback ignoring error: Can't use string ("320") as an ARRAY ref while "strict refs" in use at t/overrides.t line 235.
*** menu position callback must return two integers (x, y) or two integers and a boolean (x, y, push_in) at /builddir/build/BUILD/Gtk3-0.019/blib/lib/Gtk3.pm line 937.
*** menu position callback ignoring error: Can't use string ("320") as an ARRAY ref while "strict refs" in use at t/overrides.t line 235.
*** menu position callback must return two integers (x, y) or two integers and a boolean (x, y, push_in) at /builddir/build/BUILD/Gtk3-0.019/blib/lib/Gtk3.pm line 937.
Can't find information for method Pixbuf::save at t/overrides.t line 639.
# Looks like you planned 164 tests but ran 144.
# Looks like your test exited with 1 just after 144.
t/overrides.t .................. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 20/164 subtests 
	(less 55 skipped subtests: 89 okay)

This happens since upgrading gdk-pixbuf2 from 2.31.2-2.fc23 to 2.31.3-1.fc23.

Comment 1 Petr Šabata 2015-05-06 14:40:23 UTC
Created attachment 1022709 [details]
Fix the position error

This fixes the first, non-fatal position callback error.

I can't tell whether this is a new thing or whether it's been broken the whole time.  It might require some Gtk/Gdk version checks around it.

Comment 2 Petr Pisar 2015-07-13 12:26:49 UTC
*** Bug 1239613 has been marked as a duplicate of this bug. ***

Comment 3 Petr Pisar 2015-07-13 12:48:14 UTC
Gtk3-0.022 fixed the real error caused by the gdk-pixbuf2 change.


Note You need to log in before you can comment on or make changes to this bug.