Bug 1200031 - observed validity of 24 hour subscription is 2 days
Summary: observed validity of 24 hour subscription is 2 days
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-09 14:44 UTC by Shwetha Kallesh
Modified: 2015-03-13 14:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-13 14:35:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shwetha Kallesh 2015-03-09 14:44:55 UTC
Description of problem:
observed validity of 24 hour subscription is 2 days

Version-Release number of selected component (if applicable):

[root@dhcp35-188 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.45-1
subscription management rules: 5.14
subscription-manager: 1.14.1-1.git.84.66aafd7.el6
python-rhsm: 1.14.2-1.git.0.fafb02d.el6

How reproducible:


Steps to Reproduce:
    [root@dhcp35-188 ~]# subscription-manager register --force
    The system with UUID 3df63d78-2c12-49bd-96b2-ae485227581f has been unregistered
    Username: admin
    Password:
    Organization: admin
    The system has been registered with ID: b9ab72bc-c73f-4c33-a3ec-d13da8978641
    [root@dhcp35-188 ~]# subscription-manager attach --auto
     
     
    Installed Product Current Status:
    Product Name: Awesome OS Instance Server Bits
    Status:       Partially Subscribed
     
    [root@dhcp35-188 ~]# subscription-manager list --consumed
    +-------------------------------------------+
       Consumed Subscriptions
    +-------------------------------------------+
    Subscription Name:   Awesome OS Instance Based one socket
    Provides:            Awesome OS Instance Server Bits
    SKU:                 awesomeos-onesocketib
    Contract:            0
    Account:             12331131231
    Serial:              7954350025814026147
    Pool ID:             8ac681e44bf828b6014bf82997e7072d
    Provides Management: No
    Active:              True
    Quantity Used:       1
    Service Level:       Standard
    Service Type:        L1-L3
    Status Details:      Subscription is current
    Subscription Type:   Instance Based
    Starts:              03/08/2015
    Ends:                03/10/2015   }---------> observe the subscription is valid for 2 days
    System Type:         Virtual


Actual results:


Expected results:


Additional info:

Comment 2 John Sefler 2015-03-09 22:25:22 UTC
I believe the following comment explains the observation Shwetha is making in this bug...
https://bugzilla.redhat.com/show_bug.cgi?id=1199670#c2

Comment 3 Devan Goodwin 2015-03-13 14:35:17 UTC
Closing for reasons given in bug #1199670, the certificate is still valid from subscription start time, until 24 hours after registration. The 2 days is just throwing folks off due to deployment of test data but critically it should expire at the correct time.


Note You need to log in before you can comment on or make changes to this bug.