Bug 1200045 - "extlinux --update /boot/extlinux" not including initrd line
"extlinux --update /boot/extlinux" not including initrd line
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grubby (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-09 11:15 EDT by Troy Dawson
Modified: 2015-12-09 02:49 EST (History)
7 users (show)

See Also:
Fixed In Version: grubby-8.28-12.el7
Doc Type: Bug Fix
Doc Text:
Cause: extlinux config files have slightly different format that grub-0.97 config files, but the code to parse them was inheriting from grub-0.97's config parser. Consequence: grubby expected some things in the grub-0.97 format that weren't. Fix: Make grubby handle extlinux's format correctly. Result: It doesn't fail any more.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:55:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2082633 None None None Never

  None (edit)
Description Troy Dawson 2015-03-09 11:15:51 EDT
Description of problem:
When updating cloud machine (both AWS and GCE) from RHEL 7.0 to 7.1, they will not reboot.  They fail with the error that it could not find a bootable filesystem.
Investigation shows that /boot/extlinux/extlinux.conf is not getting updated correctly.

Version-Release number of selected component (if applicable):
syslinux-extlinux-4.05-12.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start with a RHEL 7.0 machine on AWS or GCE
2. yum update
3. look at /boot/extlinux/extlinux.conf
3a. You could also reboot, but then you get the error of not being able to boot in the cloud, and that's a pain to debug.

Actual results:
# cat /boot/extlinux/extlinux.conf
# extlinux.conf generated by anaconda

ui menu.c32

menu autoboot Welcome to Red Hat Enterprise Linux. Automatic boot in # second{,s}. Press a key for options.
menu title Red Hat Enterprise Linux Boot Options.
menu hidden

timeout 1
#totaltimeout 9000


label Red Hat Enterprise Linux Server (3.10.0-229.el7.x86_64) 7.1 (Maipo)
        kernel /vmlinuz-3.10.0-229.el7.x86_64
        append no_timer_check vconsole.keymap=us console=ttyS0,115200n8 vconsole.font=latarcyrheb-sun16 root=/dev/mapper/rootvg-rootvol rd.lvm.lv=rootvg/rootvol crashkernel=auto LANG=en_US.UTF-8

label Red Hat Enterprise Linux (3.10.0-123.6.3.el7.x86_64)
        kernel /vmlinuz-3.10.0-123.6.3.el7.x86_64
        append no_timer_check vconsole.keymap=us console=ttyS0,115200n8 vconsole.font=latarcyrheb-sun16 root=/dev/mapper/rootvg-rootvol rd.lvm.lv=rootvg/rootvol crashkernel=auto LANG=en_US.UTF-8
        initrd /initramfs-3.10.0-123.6.3.el7.x86_64.img


Expected results:
# cat /boot/extlinux/extlinux.conf
# extlinux.conf generated by anaconda

ui menu.c32

menu autoboot Welcome to Red Hat Enterprise Linux. Automatic boot in # second{,s}. Press a key for options.
menu title Red Hat Enterprise Linux Boot Options.
menu hidden

timeout 1
#totaltimeout 9000


label Red Hat Enterprise Linux Server (3.10.0-229.el7.x86_64) 7.1 (Maipo)
        kernel /vmlinuz-3.10.0-229.el7.x86_64
        append no_timer_check vconsole.keymap=us console=ttyS0,115200n8 vconsole.font=latarcyrheb-sun16 root=/dev/mapper/rootvg-rootvol rd.lvm.lv=rootvg/rootvol crashkernel=auto LANG=en_US.UTF-8
        initrd /initramfs-3.10.0-229.el7.x86_64.img

label Red Hat Enterprise Linux (3.10.0-123.6.3.el7.x86_64)
        kernel /vmlinuz-3.10.0-123.6.3.el7.x86_64
        append no_timer_check vconsole.keymap=us console=ttyS0,115200n8 vconsole.font=latarcyrheb-sun16 root=/dev/mapper/rootvg-rootvol rd.lvm.lv=rootvg/rootvol crashkernel=auto LANG=en_US.UTF-8
        initrd /initramfs-3.10.0-123.6.3.el7.x86_64.img


Additional info:
We are currently using the work-around of adding the line to our machines before rebooting them, but that is a pain in the rear when you have alot of machines.
Comment 1 Troy Dawson 2015-03-09 11:22:00 EDT
Side note: "extlinux --update /boot/extlinux" comes from the post install script of syslinux-extlinux

# rpm -q --scripts --triggers syslinux-extlinux
postinstall scriptlet (using /bin/sh):
# If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
# and update it.
if [ -f /boot/extlinux/extlinux.conf ]; then \
        extlinux --update /boot/extlinux ; \
elif [ -f /boot/extlinux.conf ]; then \
        mkdir -p /boot/extlinux && \
        mv /boot/extlinux.conf /boot/extlinux/extlinux.conf && \                                    
        extlinux --update /boot/extlinux ; \                                                        
fi
Comment 2 Troy Dawson 2015-03-10 15:08:56 EDT
Of course, after I say it is 100%, I am proven wrong.  One of the machines I updated from 7.0 to 7.1 updated /boot/extlinux/extlinux.conf correctly.
It has more packages installed than the other machines, possibly syslinux-extlinux required something the other had.
Comment 3 Troy Dawson 2015-03-10 15:25:52 EDT
I found the difference.
On the machine that worked, the kernel, and other security updates, had been updated three days before we updated the rest of the system from rhel 7.0 to 7.1.

The other systems did not have any updates from the time RHEL 7.1 was released, until we updated all the packages at the same time.
Comment 6 Troy Dawson 2015-05-05 13:14:55 EDT
The problem is ongoing, evidently it wasn't just during the update.
Now, all our machines that started at RHEL 7.0 and were updated to 7.1, do not get the initrd entry in /boot/extlinux/extlinux.conf

The problem is, there is no workaround this time.  syslinux-extlinux has already been updated, so we are having to manually update /boot/extlinux/extlinux.conf.

*****
PLEASE BUMP THIS UP IN PRIORITY.  syslinux-extlinux is clearly broken and can cause cloud machines to be unusable.
AWS doesn't have a working console on boot, so updated machines that are rebooted without manually being updated, are dead.
*****

Here is some output of the kernel post scripts, with -v added.

===
# /usr/sbin/new-kernel-pkg -v --package kernel --mkinitrd --dracut --depmod --update 3.10.0-229.1.2.el7.x86_64
initrdfile is /boot/initramfs-3.10.0-229.1.2.el7.x86_64.img
running depmod for 3.10.0-229.1.2.el7.x86_64
creating initrd: dracut  -f /boot/initramfs-3.10.0-229.1.2.el7.x86_64.img 3.10.0-229.1.2.el7.x86_64
found /boot/initramfs-3.10.0-229.1.2.el7.x86_64.img and using it with grubby
/etc/grub.conf does not exist, not running grubby
/etc/grub2.cfg does not exist, not running grubby
/etc/grub2-efi.cfg does not exist, not running grubby
/etc/lilo.conf does not exist, not running grubby
/boot/boot.scr does not exist, not setting up 
updating 3.10.0-229.1.2.el7.x86_64 from /boot/extlinux/extlinux.conf
- Making a normal entry.


# /usr/sbin/new-kernel-pkg -v --package kernel --rpmposttrans 3.10.0-229.1.2.el7.x86_64
initrdfile is /boot/initrd-3.10.0-229.1.2.el7.x86_64.img


# cat /boot/extlinux/extlinux.conf 
ui menu.c32

menu autoboot Welcome to Red Hat Enterprise Linux. Automatic boot in # second{,s}. Press a key for options.
menu title Red Hat Enterprise Linux Boot Options.
menu hidden

timeout 1
#totaltimeout 9000

label Red Hat Enterprise Linux Server (3.10.0-229.1.2.el7.x86_64) 7.1 (Maipo)
        kernel /vmlinuz-3.10.0-229.1.2.el7.x86_64
        append no_timer_check vconsole.keymap=us console=ttyS0,115200n8 vconsole.font=latarcyrheb-sun16 root=/dev/mapper/rootvg-rootvol rd.lvm.lv=rootvg/rootvol crashkernel=auto LANG=en_US.UTF-8

label Red Hat Enterprise Linux Server (3.10.0-229.el7.x86_64) 7.0 (Maipo)
        kernel /vmlinuz-3.10.0-229.el7.x86_64
        append no_timer_check vconsole.keymap=us console=ttyS0,115200n8 vconsole.font=latarcyrheb-sun16 root=/dev/mapper/rootvg-rootvol rd.lvm.lv=rootvg/rootvol crashkernel=auto LANG=en_US.UTF-8
        initrd /initramfs-3.10.0-229.el7.x86_64.img

===
Comment 7 Troy Dawson 2015-05-05 13:55:15 EDT
So, in looking at work-arounds, I found another related item.
I took the latest official RHEL 7.1 AWS image.  Booted it up, and update it's kernel.  These images have grub and grub2 installed.
The /boot/grub/grub2.cfg was correct.  But the same missing initrd issue happened to the grub.conf.

# cat /etc/grub.conf 
default=0
timeout=0

title Red Hat Enterprise Linux Server (3.10.0-229.1.2.el7.x86_64) 7.1 (Maipo)
        root (hd0)
        kernel /boot/vmlinuz-3.10.0-229.1.2.el7.x86_64 ro root=UUID=6785eb86-c596-4229-85fb-4d30c848c6e8 console=hvc0 LANG=en_US.UTF-8
title Red Hat Enterprise Linux 7 (3.10.0-229.el7.x86_64)
        root (hd0)
        kernel /boot/vmlinuz-3.10.0-229.el7.x86_64 ro root=UUID=6785eb86-c596-4229-85fb-4d30c848c6e8 console=hvc0 LANG=en_US.UTF-8
        initrd /boot/initramfs-3.10.0-229.el7.x86_64.img


This is the stock image, I made no changes to it other than updating the packages.

This doesn't affect the bootup, because grub2 was configured correctly, but it's possible that the same issue is affecting both extlinux and grub.
Comment 12 errata-xmlrpc 2015-11-19 07:55:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2110.html

Note You need to log in before you can comment on or make changes to this bug.