Bug 1200146 - libkysguard package is missing dependency
Summary: libkysguard package is missing dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libksysguard
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-09 20:33 UTC by Peter Laursen
Modified: 2015-03-18 10:27 UTC (History)
1 user (show)

Fixed In Version: bluedevil-5.2.1-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-18 10:27:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Laursen 2015-03-09 20:33:32 UTC
On my Fedora 22 (from rawhide) w. XFCE destop YUM reports a package ksysguard-libs 4.11.16-7.fc22 ready for upgrade (I use KSySGuard despite I am not using KDE). But it fails to install with a depencency error.

Package: 1:ksysguard-libs-4.11.16-7.fc22.x86_64 (updates-testing)
    Requires: libksysguard-common >= 5
(translated from Danish)



This has persisted for 3 weeks now, I think, so I thought I'd report it. It seems noone has noticed.  Not a big issue obviously, but ooks like an oversightto me..

Comment 1 Fedora Update System 2015-03-09 21:31:47 UTC
bluedevil-5.2.1-2.fc22, kde-cli-tools-5.2.1-4.fc22, kdecoration-5.2.1-2.fc22, kdeplasma-addons-5.2.1-2.fc22, kf5-kwayland-5.2.1-2.fc22, kf5-modemmanager-qt-5.2.1-2.fc22, khelpcenter-5.2.1-2.fc22, khotkeys-5.2.1-2.fc22, kinfocenter-5.2.1-2.fc22, kio-extras-5.2.1-2.fc22, kmenuedit-5.2.1-2.fc22, kscreen-5.2.1-3.fc22, ksshaskpass-5.2.1-2.fc22, ksysguard-5.2.1-2.fc22, kwin-5.2.1-4.fc22, kwrited-5.2.1-2.fc22, libbluedevil-5.2.1-2.fc22, libkscreen-qt5-5.2.1-2.fc22, libksysguard-5.2.1-3.fc22, plasma-breeze-5.2.1-2.fc22, plasma-desktop-5.2.1-5.fc22, plasma-milou-5.2.1-2.fc22, plasma-nm-5.2.1-2.fc22, plasma-oxygen-5.2.1-2.fc22, plasma-systemsettings-5.2.1-2.fc22, plasma-workspace-5.2.1-2.fc22, plasma-workspace-wallpapers-5.2.1-2.fc22, polkit-kde-5.2.1-2.fc22, powerdevil-5.2.1-2.fc22, sddm-kcm-5.2.1-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/bluedevil-5.2.1-2.fc22,kde-cli-tools-5.2.1-4.fc22,kdecoration-5.2.1-2.fc22,kdeplasma-addons-5.2.1-2.fc22,kf5-kwayland-5.2.1-2.fc22,kf5-modemmanager-qt-5.2.1-2.fc22,khelpcenter-5.2.1-2.fc22,khotkeys-5.2.1-2.fc22,kinfocenter-5.2.1-2.fc22,kio-extras-5.2.1-2.fc22,kmenuedit-5.2.1-2.fc22,kscreen-5.2.1-3.fc22,ksshaskpass-5.2.1-2.fc22,ksysguard-5.2.1-2.fc22,kwin-5.2.1-4.fc22,kwrited-5.2.1-2.fc22,libbluedevil-5.2.1-2.fc22,libkscreen-qt5-5.2.1-2.fc22,libksysguard-5.2.1-3.fc22,plasma-breeze-5.2.1-2.fc22,plasma-desktop-5.2.1-5.fc22,plasma-milou-5.2.1-2.fc22,plasma-nm-5.2.1-2.fc22,plasma-oxygen-5.2.1-2.fc22,plasma-systemsettings-5.2.1-2.fc22,plasma-workspace-5.2.1-2.fc22,plasma-workspace-wallpapers-5.2.1-2.fc22,polkit-kde-5.2.1-2.fc22,powerdevil-5.2.1-2.fc22,sddm-kcm-5.2.1-2.fc22

Comment 2 Fedora Update System 2015-03-13 17:24:53 UTC
Package bluedevil-5.2.1-2.fc22, kdecoration-5.2.1-2.fc22, kdeplasma-addons-5.2.1-2.fc22, kf5-kwayland-5.2.1-2.fc22, kf5-modemmanager-qt-5.2.1-2.fc22, khelpcenter-5.2.1-2.fc22, khotkeys-5.2.1-2.fc22, kinfocenter-5.2.1-2.fc22, kio-extras-5.2.1-2.fc22, kmenuedit-5.2.1-2.fc22, kscreen-5.2.1-3.fc22, ksshaskpass-5.2.1-2.fc22, ksysguard-5.2.1-2.fc22, kwin-5.2.1-4.fc22, kwrited-5.2.1-2.fc22, libbluedevil-5.2.1-2.fc22, libkscreen-qt5-5.2.1-2.fc22, libksysguard-5.2.1-3.fc22, plasma-milou-5.2.1-2.fc22, plasma-nm-5.2.1-2.fc22, plasma-oxygen-5.2.1-2.fc22, plasma-systemsettings-5.2.1-2.fc22, plasma-workspace-5.2.1-2.fc22, plasma-workspace-wallpapers-5.2.1-2.fc22, polkit-kde-5.2.1-2.fc22, powerdevil-5.2.1-2.fc22, sddm-kcm-5.2.1-2.fc22, plasma-breeze-5.2.1-3.fc22, plasma-desktop-5.2.1-6.fc22, kde-cli-tools-5.2.1-5.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluedevil-5.2.1-2.fc22 kdecoration-5.2.1-2.fc22 kdeplasma-addons-5.2.1-2.fc22 kf5-kwayland-5.2.1-2.fc22 kf5-modemmanager-qt-5.2.1-2.fc22 khelpcenter-5.2.1-2.fc22 khotkeys-5.2.1-2.fc22 kinfocenter-5.2.1-2.fc22 kio-extras-5.2.1-2.fc22 kmenuedit-5.2.1-2.fc22 kscreen-5.2.1-3.fc22 ksshaskpass-5.2.1-2.fc22 ksysguard-5.2.1-2.fc22 kwin-5.2.1-4.fc22 kwrited-5.2.1-2.fc22 libbluedevil-5.2.1-2.fc22 libkscreen-qt5-5.2.1-2.fc22 libksysguard-5.2.1-3.fc22 plasma-milou-5.2.1-2.fc22 plasma-nm-5.2.1-2.fc22 plasma-oxygen-5.2.1-2.fc22 plasma-systemsettings-5.2.1-2.fc22 plasma-workspace-5.2.1-2.fc22 plasma-workspace-wallpapers-5.2.1-2.fc22 polkit-kde-5.2.1-2.fc22 powerdevil-5.2.1-2.fc22 sddm-kcm-5.2.1-2.fc22 plasma-breeze-5.2.1-3.fc22 plasma-desktop-5.2.1-6.fc22 kde-cli-tools-5.2.1-5.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3778/bluedevil-5.2.1-2.fc22,kde-cli-tools-5.2.1-5.fc22,kdecoration-5.2.1-2.fc22,kdeplasma-addons-5.2.1-2.fc22,kf5-kwayland-5.2.1-2.fc22,kf5-modemmanager-qt-5.2.1-2.fc22,khelpcenter-5.2.1-2.fc22,khotkeys-5.2.1-2.fc22,kinfocenter-5.2.1-2.fc22,kio-extras-5.2.1-2.fc22,kmenuedit-5.2.1-2.fc22,kscreen-5.2.1-3.fc22,ksshaskpass-5.2.1-2.fc22,ksysguard-5.2.1-2.fc22,kwin-5.2.1-4.fc22,kwrited-5.2.1-2.fc22,libbluedevil-5.2.1-2.fc22,libkscreen-qt5-5.2.1-2.fc22,libksysguard-5.2.1-3.fc22,plasma-breeze-5.2.1-3.fc22,plasma-desktop-5.2.1-6.fc22,plasma-milou-5.2.1-2.fc22,plasma-nm-5.2.1-2.fc22,plasma-oxygen-5.2.1-2.fc22,plasma-systemsettings-5.2.1-2.fc22,plasma-workspace-5.2.1-2.fc22,plasma-workspace-wallpapers-5.2.1-2.fc22,polkit-kde-5.2.1-2.fc22,powerdevil-5.2.1-2.fc22,sddm-kcm-5.2.1-2.fc22
then log in and leave karma (feedback).

Comment 3 Peter Laursen 2015-03-13 19:16:22 UTC
I had already uninstalled KSySGuard a few days ago in order to check if a fresh install would solve the problem.  Untill this morning it would not - KSySGuard would not install.  I was able to intall it now.

What installed were packages "ksysguard", "ksysguardd" and "libksysguard" - all 5.2.0-0 versions.

I see "ksysguard-libs" 4.11.16.7 in "fedora-updates" repo, but it were not pulled as a depenendcy for install.


I hope this was helpful.

Comment 4 Fedora Update System 2015-03-18 10:27:40 UTC
bluedevil-5.2.1-2.fc22, kdecoration-5.2.1-2.fc22, kdeplasma-addons-5.2.1-2.fc22, kf5-kwayland-5.2.1-2.fc22, kf5-modemmanager-qt-5.2.1-2.fc22, khelpcenter-5.2.1-2.fc22, khotkeys-5.2.1-2.fc22, kinfocenter-5.2.1-2.fc22, kio-extras-5.2.1-2.fc22, kmenuedit-5.2.1-2.fc22, kscreen-5.2.1-3.fc22, ksshaskpass-5.2.1-2.fc22, ksysguard-5.2.1-2.fc22, kwin-5.2.1-4.fc22, kwrited-5.2.1-2.fc22, libbluedevil-5.2.1-2.fc22, libkscreen-qt5-5.2.1-2.fc22, libksysguard-5.2.1-3.fc22, plasma-milou-5.2.1-2.fc22, plasma-nm-5.2.1-2.fc22, plasma-oxygen-5.2.1-2.fc22, plasma-systemsettings-5.2.1-2.fc22, plasma-workspace-5.2.1-2.fc22, plasma-workspace-wallpapers-5.2.1-2.fc22, polkit-kde-5.2.1-2.fc22, powerdevil-5.2.1-2.fc22, sddm-kcm-5.2.1-2.fc22, plasma-breeze-5.2.1-3.fc22, plasma-desktop-5.2.1-6.fc22, kde-cli-tools-5.2.1-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.