Bug 1200194 - nova fails to start during instack-install-undercloud because psutil module not found
Summary: nova fails to start during instack-install-undercloud because psutil module n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 00:37 UTC by Dan Sneddon
Modified: 2015-08-05 13:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Dan Sneddon 2015-03-10 00:37:31 UTC
Description of problem:
instack-install-undercloud failed on a bare metal server because the psutil module was not found.

Version-Release number of selected component (if applicable):
instack.noarch                    0.0.6.4-g57c723a.el7.centos
instack-undercloud.noarch         2.0.0-dev1416.g5759e29.el7.centos
openstack-nova-api.noarch         2015.1-dev1630.g879c28b.el7.centos
openstack-nova-cert.noarch        2015.1-dev1630.g879c28b.el7.centos
openstack-nova-common.noarch      2015.1-dev1630.g879c28b.el7.centos
openstack-nova-compute.noarch     2015.1-dev1630.g879c28b.el7.centos
openstack-nova-conductor.noarch   2015.1-dev1630.g879c28b.el7.centos
openstack-nova-console.noarch     2015.1-dev1630.g879c28b.el7.centos
openstack-nova-novncproxy.noarch  2015.1-dev1630.g879c28b.el7.centos
openstack-nova-scheduler.noarch   2015.1-dev1630.g879c28b.el7.centos


How reproducible:
Only happened once on a fresh install, did the workaround and continued.

Steps to Reproduce:
1. Build RHEL 7.1 server
2. Follow instack instructions
3. instack-install-undercloud

Actual results:
instack-install-undercloud fails because it can't reach http://<local_ip>>:8774. The nova logs say: "ImportError: No module named psutil".

Expected results:
instack-install-undercloud should install the psutil module as part of the install.

Additional info:
To work around this, I ran "sudo pip install psutil".

Comment 6 Omri Hochman 2015-07-09 18:02:19 UTC
unable to reproduce with : instack-undercloud-2.1.2-11.el7ost.noarch

Comment 8 errata-xmlrpc 2015-08-05 13:50:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.