Bug 120023 - RAID/LVM2 install without SELinux fails mount on reboot
RAID/LVM2 install without SELinux fails mount on reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 06:52 EDT by Martin Smith
Modified: 2014-03-16 22:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 16:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Smith 2004-04-05 06:52:07 EDT
Description of problem:

I set up a new installation using LVM2 on top of software RAID. At the
end of the install the reboot did not succeed. None of the LVM
filesystems had been mounted. 

Looking at the initscript I saw something related to SELinux in the
LVM2 section. I had this turned this off in my install.

Commenting out the line that removed the /proc/device_mapper/control
file and rebooting allowed the system to reboot normally. I suspect
that this file did not get recreated causing the system to fail to
initialise LVM2.

Version-Release number of selected component (if applicable):

Version included in FC2 Test 2.

How reproducible:

I didn't try to reinstall but I suspect it would happen every time.


Steps to Reproduce:
1. Install a system using LVM2 for everything except root filesystem
with SELinux disabled. 
2. Reboot at the end of the install.
3.
  
Actual results:

Boots to maintenance mode after failing fsck due to unmounted filesystems.

Expected results:

Normal boot to multiuser.

Additional info:
Comment 1 Bill Nottingham 2005-09-30 16:42:21 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Please try to reproduce this on a current release, such as Fedora Core 4. If the
issue persists, please open a new issue. This should have been solved by the
final release.

Note You need to log in before you can comment on or make changes to this bug.