Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200254 - NFS-Ganesha : Locking of global option file used by NFS-Ganesha.
Summary: NFS-Ganesha : Locking of global option file used by NFS-Ganesha.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: ganesha-nfs
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1218963
TreeView+ depends on / blocked
 
Reported: 2015-03-10 06:49 UTC by Meghana
Modified: 2016-06-16 12:43 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218963 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:43:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Meghana 2015-03-10 06:49:34 UTC
Description of problem:

The global option gluster features.ganesha enable will
write into the global 'option' file. Currently, only the snapshot
feature writes into this file. But with CLI changes getting merged,
NFS-Ganesha also writes into the same file.
http://review.gluster.org/#/c/9538/

To handle concurrent multiple transactions correctly, a new lock has to
be introduced on this file. Every operation using this file needs to contest
for the new lock type. This bug is opened to track that change.

Comment 1 Meghana 2015-03-12 04:53:44 UTC
Review comments that need to addressed :

1. In the function, __glusterd_handle_ganesha_cmd , change the log level
in gf_log to GF_LOG_DEBUG.

2. Remove validation of key/value in either commit/stage phase in
CLI global option patch.

Comment 2 Meghana 2015-03-30 09:46:39 UTC
gluster vol info shows inconsistent values for features.ganesha. Check and fix in the same patch

Comment 3 Anand Avati 2015-04-06 06:14:22 UTC
REVIEW: http://review.gluster.org/10130 (NFS-Ganesha : Locking global options file) posted (#1) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 4 Anand Avati 2015-04-09 13:13:50 UTC
REVIEW: http://review.gluster.org/10130 (NFS-Ganesha : Locking global options file) posted (#2) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 5 Anand Avati 2015-04-21 10:31:43 UTC
REVIEW: http://review.gluster.org/10130 (NFS-Ganesha : Locking global options file) posted (#3) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 6 Anand Avati 2015-05-05 12:25:55 UTC
REVIEW: http://review.gluster.org/10130 (NFS-Ganesha : Locking global options file) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 7 Anand Avati 2015-05-06 04:24:33 UTC
REVIEW: http://review.gluster.org/10130 (NFS-Ganesha : Locking global options file) posted (#6) for review on master by Meghana M (mmadhusu@redhat.com)

Comment 8 Anand Avati 2015-05-06 12:33:59 UTC
COMMIT: http://review.gluster.org/10130 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 403a74da5d3287489829c629d42643b8b320ee62
Author: Meghana Madhusudhan <mmadhusu@redhat.com>
Date:   Mon Apr 20 10:41:47 2015 +0530

    NFS-Ganesha : Locking global options file
    
    Global option gluster features.ganesha enable
    writes into the global 'option' file. The snapshot
    feature also writes into the same file.
    
    To handle concurrent multiple transactions correctly,
    a new lock has to be introduced on this file.
    Every operation using this file needs
    to contest for the new lock type.
    
    Change-Id: Ia8a324d2a466717b39f2700599edd9f345b939a9
    BUG: 1200254
    Signed-off-by: Meghana Madhusudhan <mmadhusu@redhat.com>
    Reviewed-on: http://review.gluster.org/10130
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: soumya k <skoduri@redhat.com>
    Tested-by: NetBSD Build System
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 11 Nagaprasad Sathyanarayana 2015-10-25 14:53:32 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 12 Niels de Vos 2016-06-16 12:43:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.