Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200264 - Upcall: Support to handle upcall notifications asynchronously
Summary: Upcall: Support to handle upcall notifications asynchronously
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: GlusterFS
Classification: Community
Component: upcall
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard: FutureFeature
Depends On:
Blocks: 1200262
TreeView+ depends on / blocked
 
Reported: 2015-03-10 07:25 UTC by Soumya Koduri
Modified: 2019-04-17 15:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-17 15:40:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Soumya Koduri 2015-03-10 07:25:43 UTC
Description of problem:

This is with respect to one of the review comments received - 
http://review.gluster.org/#/c/9535/9/xlators/features/upcall/src/upcall-internal.c

Add support to send upcall notifications asynchronously.

Comment 1 Yaniv Kaul 2019-04-17 09:28:36 UTC
Status?

Comment 2 Soumya Koduri 2019-04-17 13:22:11 UTC
Still a todo..No one has worked on it yet.

Also since upcall notifications are now consumed by multiple cache layers (like md-cache, nl-cache etc) and not just nfs-ganesha, we need to check with those xlator maintainers if making them asynchronous doesn't pose any issue wrt cache-coherency expected.

Comment 3 Yaniv Kaul 2019-04-17 13:45:07 UTC
(In reply to Soumya Koduri from comment #2)
> Still a todo..No one has worked on it yet.
> 
> Also since upcall notifications are now consumed by multiple cache layers
> (like md-cache, nl-cache etc) and not just nfs-ganesha, we need to check
> with those xlator maintainers if making them asynchronous doesn't pose any
> issue wrt cache-coherency expected.

Since this was filed ~4 years ago - do we expect anyone to work on this?


Note You need to log in before you can comment on or make changes to this bug.