Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200271 - Upcall: xlator options for Upcall xlator
Summary: Upcall: xlator options for Upcall xlator
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: upcall
Version: mainline
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Soumya Koduri
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1200262 1217711 1217723
TreeView+ depends on / blocked
 
Reported: 2015-03-10 07:43 UTC by Soumya Koduri
Modified: 2016-06-16 12:43 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1217723 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:43:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Soumya Koduri 2015-03-10 07:43:56 UTC
Description of problem:

This bug is to track changes for upcall xlator options required to enable cache_invalidation and lease_locks support.

Also this will track the changes required to handle cache_invalidation for all the fops which are missed out in the bug1200262.

Comment 1 Soumya Koduri 2015-03-16 13:20:52 UTC
In addition - will address below comments received as part of
http://review.gluster.org/#/c/9535 - 

* skip cache_invalidation notifications only in case of internal Gluster fops. Can check using frame->root->pid.

Comment 2 Anand Avati 2015-03-24 05:04:42 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 3 Anand Avati 2015-03-25 07:37:56 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#2) for review on master by soumya k (skoduri@redhat.com)

Comment 4 Anand Avati 2015-03-25 07:43:51 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#3) for review on master by soumya k (skoduri@redhat.com)

Comment 5 Anand Avati 2015-03-26 07:00:43 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#4) for review on master by soumya k (skoduri@redhat.com)

Comment 6 Anand Avati 2015-03-26 07:09:42 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#5) for review on master by soumya k (skoduri@redhat.com)

Comment 7 Anand Avati 2015-03-30 11:52:13 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#6) for review on master by soumya k (skoduri@redhat.com)

Comment 8 Anand Avati 2015-03-31 06:54:49 UTC
REVIEW: http://review.gluster.org/9975 (Upcall: Added xlator options to enable cache-invalidation) posted (#7) for review on master by soumya k (skoduri@redhat.com)

Comment 9 Anand Avati 2015-03-31 18:16:31 UTC
COMMIT: http://review.gluster.org/9975 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 25f97b2788a33efcb0714ad639f8db380b864982
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Tue Mar 24 10:30:31 2015 +0530

    Upcall: Added xlator options to enable cache-invalidation
    
    Added two xlator options to enable cache-invalidation and set
    cache-invalidation-timeout.
    
    In addition, made few minor changes in the upcall processing code
    in gfapi.
    
    Change-Id: Ie0b32ca8348e34e3fe4f1e7df30cc925fa4aad31
    BUG: 1200271
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/9975
    Reviewed-by: Meghana M <mmadhusu@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 10 Anand Avati 2015-04-10 10:35:06 UTC
REVIEW: http://review.gluster.org/10194 (Upcall: Handle missing fops in the upcall xlator) posted (#1) for review on master by soumya k (skoduri@redhat.com)

Comment 11 Soumya Koduri 2015-04-10 10:36:12 UTC
Internal gluster fops cannot be skipped for cache_invalidation as few of them like self-healing will result in data change.

Comment 12 Anand Avati 2015-04-10 18:37:49 UTC
REVIEW: http://review.gluster.org/10194 (Upcall: Handle missing fops in the upcall xlator) posted (#2) for review on master by soumya k (skoduri@redhat.com)

Comment 13 Anand Avati 2015-04-17 10:00:06 UTC
REVIEW: http://review.gluster.org/10194 (Upcall: Handle missing fops in the upcall xlator) posted (#3) for review on master by soumya k (skoduri@redhat.com)

Comment 14 Anand Avati 2015-04-29 18:19:26 UTC
REVIEW: http://review.gluster.org/10194 (eUpcall: Handle missing fops in the upcall xlator) posted (#4) for review on master by soumya k (skoduri@redhat.com)

Comment 15 Anand Avati 2015-04-30 05:05:36 UTC
REVIEW: http://review.gluster.org/10194 (eUpcall: Handle missing fops in the upcall xlator) posted (#5) for review on master by soumya k (skoduri@redhat.com)

Comment 16 Anand Avati 2015-04-30 05:14:03 UTC
REVIEW: http://review.gluster.org/10194 (eUpcall: Handle missing fops in the upcall xlator) posted (#6) for review on master by soumya k (skoduri@redhat.com)

Comment 17 Anand Avati 2015-04-30 08:02:04 UTC
REVIEW: http://review.gluster.org/10194 (Upcall: Handle missing fops in the upcall xlator) posted (#7) for review on master by soumya k (skoduri@redhat.com)

Comment 18 Anand Avati 2015-05-01 09:19:13 UTC
REVIEW: http://review.gluster.org/10194 (Upcall: Handle missing fops in the upcall xlator) posted (#8) for review on master by soumya k (skoduri@redhat.com)

Comment 19 Anand Avati 2015-05-02 17:31:03 UTC
REVIEW: http://review.gluster.org/10194 (Upcall: Handle missing fops in the upcall xlator) posted (#9) for review on master by soumya k (skoduri@redhat.com)

Comment 20 Niels de Vos 2015-05-14 17:26:51 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 21 Niels de Vos 2015-05-14 17:28:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 22 Niels de Vos 2015-05-14 17:35:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 23 Niels de Vos 2016-06-16 12:43:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.