Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200282 - Warning info about DNS always shows up when run openshift command.
Summary: Warning info about DNS always shows up when run openshift command.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Containers
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 08:20 UTC by Yanping Zhang
Modified: 2015-05-15 03:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-21 18:00:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yanping Zhang 2015-03-10 08:20:32 UTC
Description of problem:
On env where "openshift start" is running, when run openshift command, such as "openshift ex -h", "openshift version" and so on, there is always a warning info shown up:
"W0310 14:55:07.848529   24050 config.go:111] Unable to bind DNS as 0.0.0.0:53 (you may need to run as root), using 0.0.0.0:8053 which will not resolve from all locations"

Check the port 53, it's occupied by "openshift start" process:
 #lsof -i :53
COMMAND     PID USER   FD   TYPE   DEVICE SIZE/OFF NODE NAME
openshift 17731 root   18u  IPv6 13155977      0t0  TCP *:domain (LISTEN)
openshift 17731 root   20u  IPv6 13155979      0t0  UDP *:domain 

If terminate "openshift start", running "openshift version" works well.

Version-Release number of selected component (if applicable):
openshift v0.4.1-13-g479dbbd
kubernetes v0.11.0-330-g6241a21


How reproducible:
Always

Steps to Reproduce:
1.Setup a allinone env from source code.
Clone source code from https://gitbug.com/openshift/origin. Build from the code.Start openshift
#openshift start
2.Run any openshift command.
#openshift version
3.

Actual results:
2.# openshift version
W0310 15:06:46.505493   24355 config.go:111] Unable to bind DNS as 0.0.0.0:53 (you may need to run as root), using 0.0.0.0:8053 which will not resolve from all locations
openshift v0.4.1-13-g479dbbd
kubernetes v0.11.0-330-g6241a21


Expected results:
2. Should not have the warning info for all openshift command .

Additional info:
Can be reproduced on fedora_1003.

Comment 1 Brenton Leanhardt 2015-03-16 12:23:09 UTC
https://github.com/openshift/origin/pull/1263

Comment 2 Yanping Zhang 2015-03-17 02:14:55 UTC
# openshift version
openshift v0.4.1-101-g0ac00c6
kubernetes v0.11.0-330-g6241a21
QE found the issue has been fixed in current version. Once the bug is ON_QA, QE will verify it.

Comment 3 Yanping Zhang 2015-03-18 01:42:59 UTC
# openshift version
openshift v0.4.1-126-g69a3203
kubernetes v0.11.0-330-g6241a21
Tested on current version, after ran "openshift start", executed openshift command such as "openshift ex", it didn't have "DNS" warning info.
So the issue is fixed. Move the bug to verified.


Note You need to log in before you can comment on or make changes to this bug.