Bug 12003 - Can't find Qt libraries
Summary: Can't find Qt libraries
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-08 23:24 UTC by Peter Medley
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 19:47:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Medley 2000-06-08 23:24:30 UTC
I can't download any programs because there is always a dependency problem 
in that it can never find the Qt libraries.  I know they're there because 
I'm running KDE.

Comment 1 Bernhard Rosenkraenzer 2000-06-12 19:46:58 UTC
Not a bug - either you forgot to istall the development packages (just the
libraries won't help you compile anything - you need the headers etc), or you're
trying to compile KDE 1.x applications with Qt 2.x or KDE 2.x applications with
Qt 1.x.

Red Hat Linux defaults to using Qt 2.x because it's better and truly free -
probably you forgot to tell the program you're trying to compile to use Qt 1.x.

Make sure you've installed qt1x-devel, then do

export QTDIR=/usr/lib/qt-1.45

and proceed with compiling.


Note You need to log in before you can comment on or make changes to this bug.