Bug 1200304 - kernel oops stopping lircd after replugging USB IR blaster (mceusb)
Summary: kernel oops stopping lircd after replugging USB IR blaster (mceusb)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 09:29 UTC by Trevor Cordes
Modified: 2015-11-04 22:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 22:19:30 UTC
Type: Bug


Attachments (Terms of Use)
messages log that shows everything that was done and oops (5.66 KB, text/plain)
2015-03-10 09:29 UTC, Trevor Cordes
no flags Details

Description Trevor Cordes 2015-03-10 09:29:11 UTC
Created attachment 999788 [details]
messages log that shows everything that was done and oops

Description of problem:
Got a kernel oops and then was unable to shutdown (more oops) after I was running tests on lircd by sending it commands using irsend, then unplugging my USB blaster/remote combo device (mceusb), then plugging it back in, then restarting lircd.  The instant I issued systemctl restart lircd.service the oops happened.

Then when I tried to reboot because lircd was majorly hung (not even killable -9) the system oopsed again (something about recursive oops and needing a reboot) and dropped to dracut shell where my keyboard wouldn't work.  Had to hit reset button.

See attached messages log.


Version-Release number of selected component (if applicable):
kernel-PAE-3.18.8-201.fc21.i686
lirc-0.9.1a-4.fc21.i686


How reproducible:
Just the once, haven't tried again on purpose yet as this is a myth server with massive RAID6 md array I don't want to lose due to oops's.  I am working on making a test rig for further testing.


Steps to Reproduce:
1. run lircd
2. unplug mceusb USB IR transceiver
3. replug mceusb
4. systemctl restart lircd.service


Actual results:
Oops (see attached)


Expected results:
No oops.  lircd happily restarts.


Additional info:
Upgrading to Fedora 21 broke my MythTV IR blaster so I am running major tests and debugs trying to get it to work again, that's the only reason I am replugging this device.  Sounds like the lirc IR drivers are now in the kernel.  Obviously we don't want null pointer derefs when you plug in usb devices.  This blaster has worked 100% in previous Fedora's (19 and earlier) for 8+ years.  I skipped F20 and went straight to F21.

#lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 0471:0815 Philips (or NXP) eHome Infrared Receiver
Bus 002 Device 002: ID 046d:c313 Logitech, Inc. Internet 350 Keyboard
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Comment 1 Fedora Kernel Team 2015-04-28 18:31:40 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.19.5-200.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 22, and are still experiencing this issue, please change the version to Fedora 22.

If you experience different issues, please open a new bug report for those.

Comment 2 Fedora End Of Life 2015-11-04 12:24:37 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Trevor Cordes 2015-11-04 22:19:30 UTC
I only ever saw this bug while bug #1200353 was unfixed.  I can see how bug #1200353 caused this bug to occur as the driver was being left in a wonky state.  Let's close this bug as "won't happen again" because of the fix for #1200353.


Note You need to log in before you can comment on or make changes to this bug.