Bug 1200377 - [abrt] Crash when moving away from a meeting invitation email
Summary: [abrt] Crash when moving away from a meeting invitation email
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3a02093ccf7e777131341b5c7a2...
: 1196093 1202422 1203668 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 12:43 UTC by Peter Robinson
Modified: 2015-03-20 05:45 UTC (History)
8 users (show)

Fixed In Version: evolution-3.15.92
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1327668 (view as bug list)
Environment:
Last Closed: 2015-03-20 05:45:52 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (79.65 KB, text/plain)
2015-03-10 12:43 UTC, Peter Robinson
no flags Details
File: cgroup (190 bytes, text/plain)
2015-03-10 12:43 UTC, Peter Robinson
no flags Details
File: core_backtrace (60.29 KB, text/plain)
2015-03-10 12:43 UTC, Peter Robinson
no flags Details
File: dso_list (27.17 KB, text/plain)
2015-03-10 12:43 UTC, Peter Robinson
no flags Details
File: environ (2.08 KB, text/plain)
2015-03-10 12:43 UTC, Peter Robinson
no flags Details
File: limits (1.29 KB, text/plain)
2015-03-10 12:44 UTC, Peter Robinson
no flags Details
File: maps (130.61 KB, text/plain)
2015-03-10 12:44 UTC, Peter Robinson
no flags Details
File: open_fds (3.75 KB, text/plain)
2015-03-10 12:44 UTC, Peter Robinson
no flags Details
File: proc_pid_status (963 bytes, text/plain)
2015-03-10 12:44 UTC, Peter Robinson
no flags Details
File: var_log_messages (6.62 KB, text/plain)
2015-03-10 12:44 UTC, Peter Robinson
no flags Details

Description Peter Robinson 2015-03-10 12:43:49 UTC
Description of problem:
Calendar related crash. Just have to try and accept a meeting request

Version-Release number of selected component:
evolution-3.15.91-1.fc22

Additional info:
reporter:       libreport-2.4.0
backtrace_rating: 4
cmdline:        evolution
crash_function: g_type_check_instance_is_fundamentally_a
executable:     /usr/bin/evolution
kernel:         4.0.0-0.rc2.git0.1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_type_check_instance_is_fundamentally_a at gtype.c:4028
 #2 itip_view_finalize at itip-view.c:1314
 #4 g_datalist_clear at gdataset.c:273
 #5 g_object_finalize at gobject.c:1033
 #7 WebKit::DOMObjectCache::clearByFrame at Source/WebCore/bindings/gobject/DOMObjectCache.cpp:109
 #8 WebCore::FrameLoader::commitProvisionalLoad at Source/WebCore/loader/FrameLoader.cpp:1817
 #9 WebCore::DocumentLoader::commitLoad at Source/WebCore/loader/DocumentLoader.cpp:765
 #10 WebCore::DocumentLoader::continueAfterContentPolicy at Source/WebCore/loader/DocumentLoader.cpp:752
 #11 WebCore::DocumentLoader::responseReceived at Source/WebCore/loader/DocumentLoader.cpp:655
 #12 WebCore::DocumentLoader::handleSubstituteDataLoadNow at Source/WebCore/loader/DocumentLoader.cpp:475

Comment 1 Peter Robinson 2015-03-10 12:43:53 UTC
Created attachment 999884 [details]
File: backtrace

Comment 2 Peter Robinson 2015-03-10 12:43:54 UTC
Created attachment 999885 [details]
File: cgroup

Comment 3 Peter Robinson 2015-03-10 12:43:56 UTC
Created attachment 999886 [details]
File: core_backtrace

Comment 4 Peter Robinson 2015-03-10 12:43:58 UTC
Created attachment 999887 [details]
File: dso_list

Comment 5 Peter Robinson 2015-03-10 12:43:59 UTC
Created attachment 999888 [details]
File: environ

Comment 6 Peter Robinson 2015-03-10 12:44:01 UTC
Created attachment 999889 [details]
File: limits

Comment 7 Peter Robinson 2015-03-10 12:44:03 UTC
Created attachment 999890 [details]
File: maps

Comment 8 Peter Robinson 2015-03-10 12:44:04 UTC
Created attachment 999891 [details]
File: open_fds

Comment 9 Peter Robinson 2015-03-10 12:44:06 UTC
Created attachment 999892 [details]
File: proc_pid_status

Comment 10 Peter Robinson 2015-03-10 12:44:07 UTC
Created attachment 999893 [details]
File: var_log_messages

Comment 11 Peter Robinson 2015-03-10 12:44:51 UTC
Crashes every time without fail

Comment 12 Milan Crha 2015-03-11 07:07:14 UTC
Thanks fro a  bug rpeort. Please update your webkigtk3 to:
https://admin.fedoraproject.org/updates/webkitgtk3-2.4.8-5.fc22

Comment 13 Fedora Update System 2015-03-11 07:12:57 UTC
webkitgtk3-2.4.8-5.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/webkitgtk3-2.4.8-5.fc22

Comment 14 Milan Crha 2015-03-11 09:40:38 UTC
(In reply to Milan Crha from comment #12)
> Thanks fro a  bug rpeort. Please update your webkigtk3 to:
> https://admin.fedoraproject.org/updates/webkitgtk3-2.4.8-5.fc22

Oops, (apart of typos), that will not help, even it seemed to me it will. I'm sorry for that. There will be a release next week, which will have this fixed with commit [1].

Here is an evolution scratch build for Fedora 22:
http://koji.fedoraproject.org/koji/taskinfo?taskID=9202697
and here for rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=9202458
for the time till the next Monday release will hit repositories.

[1] https://git.gnome.org/browse/evolution/commit/?id=b0ebeeb

Comment 15 Peter Robinson 2015-03-11 10:21:32 UTC
> Oops, (apart of typos), that will not help, even it seemed to me it will.
> I'm sorry for that. There will be a release next week, which will have this
> fixed with commit [1].

Yippee! It works :-) and also fixes the one that I was seeing previously which appeared to only affect cancelled meeting updates.

Comment 16 Peter Robinson 2015-03-11 11:34:42 UTC
*** Bug 1196093 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2015-03-15 10:53:26 UTC
webkitgtk3-2.4.8-5.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Milan Crha 2015-03-16 17:15:17 UTC
*** Bug 1202422 has been marked as a duplicate of this bug. ***

Comment 19 Tomas Popela 2015-03-19 12:11:57 UTC
*** Bug 1203668 has been marked as a duplicate of this bug. ***

Comment 20 David Woodhouse 2015-03-19 15:07:58 UTC
Still happening with webkitgtk3-2.4.8-5.fc22 as shown in bug 1203668

Comment 21 Tomas Popela 2015-03-20 05:45:52 UTC
(In reply to David Woodhouse from comment #20)
> Still happening with webkitgtk3-2.4.8-5.fc22 as shown in bug 1203668

It is not about webkitgtk3, but about evolution, see:

> Milan Crha 2015-03-16 04:04:41 EDT
> Fixed In Version: webkitgtk3-2.4.8-5.fc22 → evolution-3.15.92

And commit https://git.gnome.org/browse/evolution/commit/?id=b0ebeeb1895fb6b85a9cd02ec2008f44e5e86f5e


Note You need to log in before you can comment on or make changes to this bug.