Bug 1200434 - atomic uninstall doesn't run uninstall command
Summary: atomic uninstall doesn't run uninstall command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lokesh Mandvekar
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 14:48 UTC by Chris Evich
Modified: 2018-11-28 08:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-28 08:02:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3723 None None None 2018-11-28 08:02:19 UTC

Description Chris Evich 2015-03-10 14:48:29 UTC
Description of problem:
I have a docker file that contains all three, 'LABEL INSTALL', 'LABEL UNINSTALL', and 'LABEL RUN'.  The commands for INSTALL and RUN work fine, but the UNINSTALL script does not run with 'atomic uninstall <image>', instead it just removes <image>

Version-Release number of selected component (if applicable):
RHEL AH 7.1 GA

How reproducible:
Very

Steps to Reproduce:
1. Make Dockerfile with all three LABELs, that run some command like 'echo test'
2. Build docker images from Dockerfile
3. atomic install <image>; atomic run <image>; atomic uninstall <image>

Actual results:
install and run work fine, however uninstall just docker rmi <image>

Expected results:
All three LABEL commands should run.

Additional info:
Related bug 1187127 and bug 1189861 maybe?

Comment 2 Colin Walters 2015-03-17 22:40:29 UTC
This component is currently in the "docker" package.

Comment 4 Daniel Walsh 2015-03-18 11:49:47 UTC
Fixed in docker-1.5.0-19.el7

Comment 5 Mike McCune 2016-03-28 22:32:18 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Edward Shen 2018-11-16 06:30:27 UTC
verified on atomic-1.22.1-26.gitb507039.el7.x86_64. It's fixed.

Comment 9 errata-xmlrpc 2018-11-28 08:02:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3723


Note You need to log in before you can comment on or make changes to this bug.