Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200564 - RHEL 5 yum content fails to sync to capsules
Summary: RHEL 5 yum content fails to sync to capsules
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Capsule
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: jaudet
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-10 20:44 UTC by jaudet
Modified: 2017-02-23 20:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-13 19:58:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description jaudet 2015-03-10 20:44:07 UTC
Description of problem:
RHEL 5 repositories do not fully sync to capsules. As a result, RHEL 5 content hosts that register to a satellite and attach an appropriate subscription are unable to consume any content.

Version-Release number of selected component (if applicable):
Produced on a RHEL 7.0 server running Satellite-6.1.0-RHEL-7-20150303.0.

How reproducible:
Unknown

Steps to Reproduce:
1. On a satellite, sync a RHEL 5 repository. For example: "Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server".
2. On that satellite, create a product which contains that repository.
3. Attach a capsule to that satellite.
4. Sync content to that capsule using a command such as `hammer capsule content synchronize ...`
5. Register a RHEL 5 content host to the capsule and attach an appropriate subscription to that content host. Attempt to list or consume content. Alternatively, check if the content has been made available with a command like this:

    test -d /var/lib/pulp/published/yum/https/repos/Default_Organization/Library/content/dist/rhel/server/5; echo $?

Actual results:
The client is unable to consume content. Instead, errors like this are emitted:

    [root@example ~]# yum repolist
    Loaded plugins: product-id, security, subscription-manager
    https://example.com/pulp/repos/Default_Organization/Library/content/dist/rhel/server/5/5Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
    Trying other mirror.
    repo id             repo name                                 status
    rhel-5-server-rpms  Red Hat Enterprise Linux 5 Server (RPMs)  0
    repolist: 0


Expected results:
The client can consume content, or the relevant directory exists and is populated with content.

Additional info:

Comment 4 jaudet 2015-03-13 19:58:29 UTC
Unable to reproduce this issue. History of commands from a RHEL 5 client:

    # history
        1  passwd
        2  rpm -Uvh http://my-capsule.example.com/pub/katello-ca-consumer-latest.noarch.rpm
        3  rm -f /etc/yum.repos.d/beaker*
        4  yum clean all
        5  subscription-manager register --org="Default_Organization" --activationkey="rhel5-oldfart"
        6  yum list --available --all
        7  subscription-manager --available --all
        8  subscription-manager list --available --all
        9  subscription-manager attach --pool 8a9084f14c0f5c9e014c0f6bb7bd009a
       10  yum repolist
       11  yum list | less
       12  yum install zsh


Note You need to log in before you can comment on or make changes to this bug.