Bug 1200625 - [RFE] ability to edit/update Start Time & Date for Sync Plans via Web UI
Summary: [RFE] ability to edit/update Start Time & Date for Sync Plans via Web UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.0.8
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Zach Huntington-Meath
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 02:49 UTC by jnikolak
Modified: 2019-09-25 21:15 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:22:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 10177 0 None None None 2016-04-26 17:05:01 UTC

Description jnikolak 2015-03-11 02:49:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
After logging into Satellite gui 
1. Go to Content -> Sync Plans
2. Create new sync plan
3. Click inside sync plan
4. There is no option to edit the sync plan

Customer would like the ability to edit the sync plan.

In addition:
There is no option to edit via cli

hammer -u *** -p *** sync-plan

    create                        Create a sync plan
    delete                        Destroy a sync plan
    info                          Show a sync plan
    list                          List sync plans
    update                        Update a sync plan

Comment 1 RHEL Program Management 2015-03-11 02:53:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 jnikolak 2015-03-12 07:21:39 UTC
Customer has found that its possible to adjust via the update command on cli, but not on gui


hammer -u <user> sync-plan update --organization "Org name" --id <ID # from list> --sync-date "2015-03-11 15:00"

Comment 4 RHEL Program Management 2015-03-16 18:33:16 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Bryan Kearney 2015-04-17 18:04:38 UTC
Created redmine issue http://projects.theforeman.org/issues/10177 from this bug

Comment 7 Bryan Kearney 2015-08-25 18:34:17 UTC
Upstream bug component is Hammer

Comment 8 Bryan Kearney 2016-03-18 22:12:26 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/10177 has been closed
-------------
Zach Huntington-Meath
Applied in changeset commit:katello|69277ef82c0426b9c4e80a104e3b6284d039ca1c.

Comment 9 Brad Buckingham 2016-04-25 14:59:42 UTC
*** Bug 1330088 has been marked as a duplicate of this bug. ***

Comment 10 Brad Buckingham 2016-04-25 15:01:55 UTC
The solution raised by this BZ also addresses the issue raised in bug 1330088; therefore, please be sure to also verify the scenario described by bug 1330088.

Comment 11 jcallaha 2016-06-09 19:40:40 UTC
Verified in Satellite 6.2 Beta Snap 15.

It is now possible to edit all components of sync plans.

Comment 12 Bryan Kearney 2016-07-27 11:22:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.