Bug 1200660 - CIFS:[USS]: .snaps is not visible or accessible from the Windows Client with Samba 4.1 even if the "show-snapshot-directory" option is set on the volume
Summary: CIFS:[USS]: .snaps is not visible or accessible from the Windows Client with ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: RHGS 3.0.4
Assignee: Jose A. Rivera
QA Contact: ssamanta
URL:
Whiteboard:
Depends On:
Blocks: 1182947
TreeView+ depends on / blocked
 
Reported: 2015-03-11 06:04 UTC by ssamanta
Modified: 2015-06-11 01:09 UTC (History)
6 users (show)

Fixed In Version: samba-4.1.17-4.el6rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-26 06:36:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0682 0 normal SHIPPED_LIVE Red Hat Storage 3.0 enhancement and bug fix update #4 2015-03-26 10:32:55 UTC

Description ssamanta 2015-03-11 06:04:40 UTC
Description of problem:
.snaps directory is not visible at the root of the share at CIFS Windows client even if "show-snapshot-directory" option is set on the volume.
It happens when using latest samba4.1.17-2.el6rhs build. With the older samba build(3.6.504-169.6.el6rhs) the .snaps is visible at the root of the share.

Version-Release number of selected component (if applicable):
[root@casino ~]# rpm -qa | grep gluster
gluster-nagios-common-0.1.4-1.el6rhs.noarch
vdsm-gluster-4.14.7.3-1.el6rhs.noarch
glusterfs-fuse-3.6.0.50-1.el6rhs.x86_64
glusterfs-libs-3.6.0.50-1.el6rhs.x86_64
glusterfs-api-3.6.0.50-1.el6rhs.x86_64
glusterfs-cli-3.6.0.50-1.el6rhs.x86_64
gluster-nagios-addons-0.1.14-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.50-1.el6rhs.x86_64
glusterfs-3.6.0.50-1.el6rhs.x86_64
glusterfs-server-3.6.0.50-1.el6rhs.x86_64
samba-vfs-glusterfs-4.1.17-2.el6rhs.x86_64
glusterfs-rdma-3.6.0.50-1.el6rhs.x86_64
[root@casino ~]#


How reproducible:
Always


Steps to Reproduce:
1.Create a 6*2 dist-rep volume and start it
2.Enable USS and features.show-snapshot-directory option on the volume
3.Create some snapshots when I/O is in progress
4.Verify the .snaps directory at the root of the share at the Windows Client.

Actual results:
The .snaps folder is not visible at the root of share when using the  samba4.1.17-2.el6rhs build.

Expected results:
.snaps should be visible at the root of share.

Additional info:

Looking at the srpm in the https://brewweb.devel.redhat.com/buildinfo?buildID=424040 link
and checking for vfs_glusterfs.c file shows that snapdir-entry-path option setting code is not present.

This is a blocker as .snaps folder is not visible at the root of share so the .snaps folder is not accessible from windows client.

Samba 3.6.504-169.6
===================
[root@gqas005 ~]# rpm -qa | grep gluster
gluster-nagios-common-0.1.4-1.el6rhs.noarch
glusterfs-api-3.6.0.50-1.el6rhs.x86_64
glusterfs-server-3.6.0.50-1.el6rhs.x86_64
gluster-nagios-addons-0.1.14-1.el6rhs.x86_64
vdsm-gluster-4.14.7.3-1.el6rhs.noarch
glusterfs-libs-3.6.0.50-1.el6rhs.x86_64
rhs-tests-rhs-tests-beaker-rhs-gluster-qe-libs-dev-bturner-2.37-0.noarch
glusterfs-3.6.0.50-1.el6rhs.x86_64
glusterfs-cli-3.6.0.50-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.50-1.el6rhs.x86_64
samba-glusterfs-3.6.509-169.6.el6rhs.x86_64
glusterfs-fuse-3.6.0.50-1.el6rhs.x86_64
glusterfs-rdma-3.6.0.50-1.el6rhs.x86_64
[root@gqas005 ~]#

[root@gqas005 ~]# gluster volume info
 
Volume Name: testvol1
Type: Distributed-Replicate
Volume ID: 915d8bc9-2778-4bd2-aa26-5aa9c9e78834
Status: Started
Snap Volume: no
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: gqas009.sbu.lab.eng.bos.redhat.com:/rhs/brick1/brick1
Brick2: gqas012.sbu.lab.eng.bos.redhat.com:/rhs/brick2/brick2
Brick3: gqas006.sbu.lab.eng.bos.redhat.com:/rhs/brick3/brick3
Brick4: gqas005.sbu.lab.eng.bos.redhat.com:/rhs/brick4/brick4
Brick5: gqas005.sbu.lab.eng.bos.redhat.com:/rhs/brick5/brick5
Brick6: gqas006.sbu.lab.eng.bos.redhat.com:/rhs/brick6/brick6
Brick7: gqas009.sbu.lab.eng.bos.redhat.com:/rhs/brick7/brick7
Brick8: gqas012.sbu.lab.eng.bos.redhat.com:/rhs/brick8/brick8
Brick9: gqas006.sbu.lab.eng.bos.redhat.com:/rhs/brick9/brick9
Brick10: gqas005.sbu.lab.eng.bos.redhat.com:/rhs/brick10/brick10
Brick11: gqas009.sbu.lab.eng.bos.redhat.com:/rhs/brick11/brick11
Brick12: gqas012.sbu.lab.eng.bos.redhat.com:/rhs/brick12/brick12
Options Reconfigured:
performance.stat-prefetch: off
storage.batch-fsync-delay-usec: 0
features.show-snapshot-directory: enable
features.uss: on
performance.readdir-ahead: on
auto-delete: disable
snap-max-soft-limit: 90
snap-max-hard-limit: 256
[root@gqas005 ~]#



[root@gqac010 ~]# mount -t cifs \\\\10.16.156.12\\gluster-testvol1 /mnt/cifs-gqas
Password:
[root@gqac010 ~]# cd /mnt/cifs-gqas
[root@gqac010 cifs-gqas]# ls -lrt
total 0
[root@gqac010 cifs-gqas]# ls -al
total 8
drwxr-xr-x.  3 root root  138 Mar 10 22:14 .
drwxr-xr-x. 13 root root 4096 Mar 10 21:38 ..
drwxr-xr-x.  2 root root 4096 Mar 10 22:26 .snaps
[root@gqac010 cifs-gqas]#

Samba 4.17
==========
[root@casino ~]# rpm -qa | grep gluster
gluster-nagios-common-0.1.4-1.el6rhs.noarch
vdsm-gluster-4.14.7.3-1.el6rhs.noarch
glusterfs-fuse-3.6.0.50-1.el6rhs.x86_64
glusterfs-libs-3.6.0.50-1.el6rhs.x86_64
glusterfs-api-3.6.0.50-1.el6rhs.x86_64
glusterfs-cli-3.6.0.50-1.el6rhs.x86_64
gluster-nagios-addons-0.1.14-1.el6rhs.x86_64
glusterfs-geo-replication-3.6.0.50-1.el6rhs.x86_64
glusterfs-3.6.0.50-1.el6rhs.x86_64
glusterfs-server-3.6.0.50-1.el6rhs.x86_64
samba-vfs-glusterfs-4.1.17-2.el6rhs.x86_64
glusterfs-rdma-3.6.0.50-1.el6rhs.x86_64
[root@casino ~]#

[root@casino ~]# gluster volume info
 
Volume Name: testvol1
Type: Distributed-Replicate
Volume ID: d838784a-1a65-4152-8b4d-66b0d123241b
Status: Started
Snap Volume: no
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: rhs-hpc-srv1.lab.eng.blr.redhat.com:/rhs/brick1/bric1
Brick2: casino.lab.eng.blr.redhat.com:/rhs/brick2/brick2
Brick3: gladiator.lab.eng.blr.redhat.com:/rhs/brick3/brick3
Brick4: rhs-gp-srv4.lab.eng.blr.redhat.com:/rhs/brick4/bric4
Brick5: rhs-hpc-srv1.lab.eng.blr.redhat.com:/rhs/brick5/bric5
Brick6: gladiator.lab.eng.blr.redhat.com:/rhs/brick3/bric3
Brick7: casino.lab.eng.blr.redhat.com:/rhs/brick2/bric2
Brick8: rhs-gp-srv4.lab.eng.blr.redhat.com:/rhs/brick9/bric9
Brick9: rhs-hpc-srv1.lab.eng.blr.redhat.com:/rhs/brick4/bric4
Brick10: casino.lab.eng.blr.redhat.com:/rhs/brick1/brick1
Brick11: gladiator.lab.eng.blr.redhat.com:/rhs/brick3/bricg
Brick12: rhs-gp-srv4.lab.eng.blr.redhat.com:/rhs/brick10/bric10
Options Reconfigured:
features.barrier: disable
features.quota-deem-statfs: on
features.quota: on
performance.readdir-ahead: on
features.uss: on
features.show-snapshot-directory: enable
storage.batch-fsync-delay-usec: 0
server.allow-insecure: enable
performance.stat-prefetch: off
auto-delete: disable
snap-max-soft-limit: 90
snap-max-hard-limit: 256
[root@casino ~]#

[root@rhsqa2 cifs-gqas]# cd /mnt/cifs
[root@rhsqa2 cifs]# ls -la
total 25
drwxr-xr-x.  5 root root  355 Mar 10 21:32 .
drwxr-xr-x.  6 root root 4096 Mar 11 02:59 ..
-rwxr--r--.  1 root root 3862 Mar  9 23:19 create_dirs_files_multi_thread.py
-rwxr--r--.  1 root root 2977 Mar 10 05:59 create_dirs_files.pl
drwxr-xr-x. 12 root root 9163 Mar 10 05:06 etc
drwxr-xr-x.  2 root root   36 Mar 10 05:12 quota-d2
[root@rhsqa2 cifs]#

Comment 3 errata-xmlrpc 2015-03-26 06:36:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0682.html


Note You need to log in before you can comment on or make changes to this bug.