Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200704 - rdma: properly handle memory registration during network interruption
Summary: rdma: properly handle memory registration during network interruption
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rdma
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1218653
TreeView+ depends on / blocked
 
Reported: 2015-03-11 09:08 UTC by Mohammed Rafi KC
Modified: 2016-06-16 12:43 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1218653 (view as bug list)
Environment:
Last Closed: 2016-06-16 12:43:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-03-11 09:08:53 UTC
Description of problem:
 
When rdma.so library is unloaded because of any problem, then we need to deregister every buffer allocated with rdma. Also when the rdma.so is again loaded, we need to do the pre registeration again.

Version-Release number of selected component (if applicable):

mainline

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-03-11 10:03:36 UTC
REVIEW: http://review.gluster.org/9854 (rdma:properly handle iobuf_pool when rdma transport is unloaded) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-03-11 14:27:03 UTC
REVIEW: http://review.gluster.org/9854 (rdma:properly handle iobuf_pool when rdma transport is unloaded) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Anand Avati 2015-04-23 18:30:17 UTC
REVIEW: http://review.gluster.org/9854 (rdma:properly handle iobuf_pool when rdma transport is unloaded) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Nagaprasad Sathyanarayana 2015-10-25 14:46:53 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 5 Nagaprasad Sathyanarayana 2015-10-25 14:54:30 UTC
Fix for this bug is already made in a GlusterFS release. The cloned BZ has details of the fix and the release. Hence closing this mainline BZ.

Comment 6 Niels de Vos 2016-06-16 12:43:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.