Bug 120077 - PCI: kernel panic on installer boot - HP NetServer LH 4
PCI: kernel panic on installer boot - HP NetServer LH 4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: FC2Target FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-04-05 16:21 EDT by Richard Nairn
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:18:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v output (5.92 KB, text/plain)
2004-04-14 10:54 EDT, Richard Nairn
no flags Details
Second "lspci -v" output (6.65 KB, text/plain)
2004-05-19 10:04 EDT, Christopher Eveland
no flags Details

  None (edit)
Description Richard Nairn 2004-04-05 16:21:45 EDT
From Bugzilla Helper:
User-Agent: Opera/7.23 (Windows NT 5.1; U)  [en]

Description of problem:
After I boot the install CD, I choose any method of installation 
(graphical,text). The kernel starts to boot up and I get this kernel 
panic. It is fairly early on, this is as much as I was able to 
capture. 

(Transcribed to paper)

Call Trace:
[<c0226f45>] class_device_create_file+0x11/0x16
[<c01d753d>] pci_alloc_child_ubs+0x74/0xb8
[<c01d7633>] pci_scan_bridge+0x90/0x1bb
[<c01d7aa1>] pci_scan_single_device+0x9/0x3b
[<c01d7b6a>] pci_scan_child_bus+0x51/0x77
[<c01d7654>] pci_scan_bridge+0xb1/0x1bb
[<c01d7aa1>] pci_scan_single_device+0x9/0x3b
[<c01d7b6a>] pci_scan_child_bus+0x51/0x77
[<c01d7cba>] pci_scan_bus_parented+0x113/0x129
[<c026e022>] pcibios_scan_root+0x3b/0x42
[<c01f4be9>] acpi_pci_root_add+0x13f/0x194
[<c01f96f0>] acpi_bus_driver_init+0x29/0x85
[<c01f93df>] acpi_bus_add+0x123/0x14f
[<c01fa553>] acpi_bus_scan+0x107/0x151
[<c036ee76>] acpi_scan_init+0x4a/0x60
[<c03616cc>] do_initcalls+0x32/0x80
[<c010718a>] init+0xbd/0x1f3
[<c01070cd>] init+0x0/0x1f3
[<c010b1d5>] kernel_thread_helper+0x5/0xb

Code: 8b 70 20 b8 b6 da 2d c0 e8 ab 9d f7 ff 8d 9e 80 00 00 00 89
<0> Kernel Panic: Attempted to kill init!

My machine is a HP NetServer LH 4, 4CPU, 1G HP NetRaid


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert FC2-test2 CD and boot
2. Select any install method,mediacheck...
3. Crash
    

Additional info:
Comment 1 Bill Nottingham 2004-04-06 16:07:13 EDT
Did this happen with test1?
Comment 2 Richard Nairn 2004-04-06 16:32:21 EDT
I haven't tried test1, test2 was the first testing set that I 
downloaded. 
Comment 3 Len Brown 2004-04-11 03:36:21 EDT
does the system install if you boot with "acpi=off" or "pci=noacpi"? 
 
do any linux kernels boot on this system?  can you attach lspci -v output? 
 
Comment 4 Richard Nairn 2004-04-14 10:54:01 EDT
Created attachment 99406 [details]
lspci -v output
Comment 5 Richard Nairn 2004-04-14 11:23:14 EDT
The machine is currently running Fedora Core 1 without any problems 
whatsoever. I was able to install and run it without any errors. 

Booting with "linux text pci=noacpi" didn't seem to change anything, 
booting with acpi=off produced this output (This was as far up the 
screen I could get):

ds: 007b es:007b ss:0068
Process swapper (pid: 1, threadinfo: f7d3e000 task=f7d35980
Stack: f7d31208 f7d31190 f7d3129c 00000002 c0226f45 c01d753d
f7d31250 c02eb500 00000000 00000002 f7df9acc f7df9acc f7d3129c 
00000001 00000000 c01d7633 c01d7aa1 00040000 44020201 f7df9acc 
f7d3129c 00000001 00000000 c01d7b6a

Call Trace:

  class_device_create_file
  pci_alloc_child_bus
  pci_scan bridge
  pci_scan_single_device
  pci_scan_child_bus
  pci_scan_bridge
  pci_scan_single_device
  pci_scan_child_bus
  pci_scan_bus_parented
  pcibios_scan_root
* [<c0378025>] pci_legacy_init+0x34/0x42
  do_init_calls
  init
  init
  kernel_thread_helper

* Modified from original.
  
Comment 6 Len Brown 2004-04-16 02:49:15 EDT
So FC1 installed and runs okay. 
How about if you boot FC1 with "acpi=on". 
 
So FC2-test2 with acpi=on (default) panics in the PCI code, called from acpi. 
and FC2-test2 with "acpi=off" panics in the PCI code called form init. 
Looking PCI-specific rather than ACPI specific at this point... 
 
Any chance you can load the latest 2.6 kernel onto FC1 and test that? 
 
 
Comment 7 Christopher Eveland 2004-05-19 10:00:16 EDT
I am getting the same problem on the recently-released FC2.  I have a
dual xeon.  Let me know if you want additional information.
Comment 8 Christopher Eveland 2004-05-19 10:04:09 EDT
Created attachment 100331 [details]
Second "lspci -v" output
Comment 9 Richard Nairn 2004-07-13 11:46:26 EDT
I tested 2.6.5 on FC1, same issue. I'll try and get a newer one and
test again.
Comment 10 Richard Nairn 2004-07-13 12:05:13 EDT
I installed the latest kernel from FC2, kernel-2.6.6-1.435smp.i686,
still get the identical output as before. (both normal and with acpi=off) 
Comment 11 Dave Jones 2004-12-07 00:50:12 EST
fixed with the 2.6.9 based kernel ?
Comment 12 Richard Nairn 2004-12-08 16:20:41 EST
No, Used the RPM from FC3, still the same error.
Comment 13 Dave Jones 2005-04-16 00:18:53 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.