Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1200787 - Inconsistent display of required checkboxes in network/clusters tab and manage networks dialog
Summary: Inconsistent display of required checkboxes in network/clusters tab and manag...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ovirt-3.6.1
: 3.6.0
Assignee: Dan Kenigsberg
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 11:47 UTC by Michael Burman
Modified: 2016-04-20 01:39 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-20 01:39:08 UTC
oVirt Team: Network
Target Upstream Version:
ylavi: Triaged+


Attachments (Terms of Use)
screenshot (2.01 MB, image/png)
2015-03-11 11:47 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 44940 0 master MERGED webadmin: fix for required checkbox in manage network popup Never
oVirt gerrit 48237 0 ovirt-engine-3.6 MERGED webadmin: fix for required checkbox in manage network popup Never

Description Michael Burman 2015-03-11 11:47:40 UTC
Created attachment 1000353 [details]
screenshot

Description of problem:
Inconsistent display of 'Attach All + Required All' checkboxes under Networks>Clusters and 'Manage Network' under Cluster

If creating new network with 'Attach All + Required All' checkboxes unchecked, there is inconsistent display of this boxes.

- Under Networks>Cluster i see the 2 of this checkboxes as unchecked.
- But if i'm entering the 'Manage Network' under Cluster, i see the 'Required All' checkboxes as checked.

Version-Release number of selected component (if applicable):
3.5.1-0.1.el6ev
3.5.0-0.34.el6ev
3.6.0-0.0.master.20150310185308.git3c75f38.el6

How reproducible:
100

Steps to Reproduce:
1. Create new network with unchecked 'Attach All + Required All' checkboxes and approve operation
2. Look the Networks>Cluster for this checkboxes
3. Look in 'Manage Network' under cluster

Actual results:
Both places display different things.

Expected results:
Should be consistent display of this checkboxes in GUI.

Comment 1 Lior Vernia 2015-03-11 12:50:11 UTC
So the problem is that the disabled required checkboxes in the dialog appear as marked by default. They could be changed to appear unmarked, and by default be marked as required whenever a network is ticked to be assigned to a cluster (to maintain the default for netowrks to be required in a cluster).

Comment 2 Alona Kaplan 2015-08-12 14:29:01 UTC
It seems that now the 'required all' and 'assigned all' checkboxes completely stopped working (in both of the dialogs).
Checking and unchecking them doesn't affect anything.

Comment 3 Yaniv Lavi 2015-08-12 20:49:37 UTC
Raising priority and severity due to comment #2.

Comment 4 Michael Burman 2015-08-18 07:33:30 UTC
Hi Eliraz, Yaniv

Like Alona wrote in comment 2 above ^^ 'required all' and 'assigned all' checkboxes completely stopped working in both dialogs. And she is right, so, is this current BZ will fix this as well? or should i report new BZ ?

Comment 5 Yaniv Lavi 2015-08-26 11:53:04 UTC
(In reply to Michael Burman from comment #4)
> Hi Eliraz, Yaniv
> 
> Like Alona wrote in comment 2 above ^^ 'required all' and 'assigned all'
> checkboxes completely stopped working in both dialogs. And she is right, so,
> is this current BZ will fix this as well? or should i report new BZ ?

I would open a separate bug, not the same use case.

Comment 6 Michael Burman 2015-08-26 12:11:30 UTC
Done. See also - https://bugzilla.redhat.com/show_bug.cgi?id=1257168

Comment 8 Michael Burman 2015-11-26 07:43:19 UTC
Verified on - 3.6.1-0.2.el6


Note You need to log in before you can comment on or make changes to this bug.