Bug 120087 - "Exit" button doesn't work in text mode and when the language isn't english
Summary: "Exit" button doesn't work in text mode and when the language isn't english
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-04-05 21:11 UTC by Daniele Scussel
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 20:49:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniele Scussel 2004-04-05 21:11:32 UTC
Description of problem:
The "exit" button doesn't work when firstboot runs in text mode and
the language isn't english.

Version-Release number of selected component (if applicable):
I tried only the version 1.3.10-1

How reproducible:
Always in text mode and language other than english.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniele Scussel 2004-04-05 21:26:24 UTC
In line 66 of the file textWindow.pl, the test below fails

if button == "exit":

I changed the line with 

if button == _("Exit").lower():

(with simply
if button == _("Exit"):
doesn't work because, at least in italian, the button value is "esci"
and the _("Exit") value is "Esci").


I don't use python, so probably you'll fix the bug better.



Comment 2 Brent Fox 2004-04-07 20:49:48 UTC
Should be fixed in firstboot-1.3.10-2 in Rawhide.


Note You need to log in before you can comment on or make changes to this bug.