Bug 1200925 - Resetting the default automate domains does not retain the domain order
Summary: Resetting the default automate domains does not retain the domain order
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.4.0
Assignee: mkanoor
QA Contact: Milan Falešník
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 16:26 UTC by Greg McCullough
Modified: 2015-08-03 14:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-16 12:52:18 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
sean.myers: automate_bug?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 0 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Internal Links: 1349113 1353645

Description Greg McCullough 2015-03-11 16:26:46 UTC
Description of problem: Resetting the default automate domains does not retain the order of the domain.  The ManageIQ domain is always set a the first domain, but other domains, like RedHat, get added as the last domain.


Version-Release number of selected component (if applicable): 5.3.x


Steps to Reproduce:
1. Have the Redhat domain available along with at least 1 other user domain which has a higher priority than the Redhat domain.
2. In the UI goto Automate -> Import/Export -> "Reset all Datastore custom classes and instances to default"

Actual results: The RedHat domain will become the highest priority domain.


Expected results: The RedHat domain should maintain the same domain order as before the reset.


Additional info:

Comment 2 CFME Bot 2015-03-18 18:00:48 UTC
New commit detected on manageiq/master:
https://github.com/ManageIQ/manageiq/commit/3877f8926a00f80766d62de560499ef1fbf1ebbd

commit 3877f8926a00f80766d62de560499ef1fbf1ebbd
Author:     Madhu Kanoor <mkanoor@redhat.com>
AuthorDate: Tue Mar 17 15:23:58 2015 -0400
Commit:     Madhu Kanoor <mkanoor@redhat.com>
CommitDate: Wed Mar 18 10:01:12 2015 -0400

    Preserve & set the priority,enabled,system of domains after db reset
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1200925

 vmdb/app/models/miq_ae_datastore.rb | 11 +++++++++++
 1 file changed, 11 insertions(+)

Comment 4 Milan Falešník 2015-04-20 14:55:13 UTC
Checked in 5.4.0.0.19, the domains keep their order and the ManageIQ domain is not allowed to be moved.

Comment 6 errata-xmlrpc 2015-06-16 12:52:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.