Bug 1200988 - Broken defaults cause bad user experience
Summary: Broken defaults cause bad user experience
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xfce4-settings
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 18:41 UTC by Toni Spets
Modified: 2017-10-25 02:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-25 02:08:53 UTC


Attachments (Terms of Use)
Proposed fix (3.89 KB, application/mbox)
2015-03-11 18:41 UTC, Toni Spets
no flags Details

Description Toni Spets 2015-03-11 18:41:05 UTC
Created attachment 1000612 [details]
Proposed fix

Description of problem:
 - default icon theme doesn't exist on RHEL/EPEL ("Fedora")
 - default cursor theme isn't consistent with Adwaita which has a cursor theme as well
 - GNOME icon theme doesn't have the "Application Finder" icon


Version-Release number of selected component (if applicable):
4.10.1-3


How reproducible:
Always.


Steps to Reproduce:
1. Install @xfce-desktop
2. Start Xfce with empty ~/.config/xfce4/
3. Get eye injury

Actual results:

Mostly everything is off as seen here: http://afb.users.sourceforge.net/xfce/centos/centos7-xfce410.png


Expected results:

Sane and clean defaults as seen here with the proposed fixes (excluding background): http://afb.users.sourceforge.net/xfce/centos/centos7-settingsfix.png



Additional info:

Proposed fixes:
 - use "GNOME" icon theme
 - use Adwaita cursor theme
 - depend on legacy GNOME icon theme package for missing icon

Attachment is against epel7 branch and addresses these issues.

Comment 1 Kevin Fenzi 2015-03-12 12:15:30 UTC
I guess this is a dupe also of: https://bugzilla.redhat.com/show_bug.cgi?id=1120030 ?

Comment 2 Toni Spets 2015-03-12 12:35:32 UTC
(In reply to Kevin Fenzi from comment #1)
> I guess this is a dupe also of:
> https://bugzilla.redhat.com/show_bug.cgi?id=1120030 ?

That is right. The icons work just fine with the legacy theme and this patch also defaults to it as well depends on.

I believe this is the proper fix.

Comment 3 Anders F Björklund 2015-03-13 18:58:03 UTC
Looking good, should have sent the patches last year but in the end didn't.

It was something with the fonts also ? But maybe that was in the comps...

Comment 4 Mukundan Ragavan 2015-03-17 02:01:55 UTC
ok, I finally got started today. will post updates once I get something done. 

https://koji.fedoraproject.org/koji/taskinfo?taskID=9247701

I haven't tested this yet though. sorry about the delay folks.

Comment 5 Toni Spets 2015-03-18 19:07:05 UTC
+1, works as intended

Comment 6 Fedora Update System 2015-03-19 00:31:28 UTC
xfce4-settings-4.10.1-4.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/xfce4-settings-4.10.1-4.el7

Comment 7 Fedora Update System 2015-04-06 03:12:26 UTC
xfce4-settings-4.10.1-4.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.