Bug 1200992 - Wrong default background causes bad user experience
Summary: Wrong default background causes bad user experience
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xfdesktop
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-03-11 18:50 UTC by Toni Spets
Modified: 2017-10-25 02:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-25 02:11:44 UTC


Attachments (Terms of Use)
Proposed fix + 4.10.3 bump (1.98 KB, application/mbox)
2015-03-11 18:50 UTC, Toni Spets
no flags Details

Description Toni Spets 2015-03-11 18:50:49 UTC
Created attachment 1000615 [details]
Proposed fix + 4.10.3 bump

Description of problem:
As the package is based off Fedora, it has a Fedora specific patch that defaults to non-existent Fedora specific background.


Version-Release number of selected component (if applicable):
4.10.2-3


How reproducible:
Always.


Steps to Reproduce:
1. Install @xfce-desktop
2. Start with clean ~/.config/xfce4/
3. Look at the sad single color background

Actual results:
No background image, only color.


Expected results:
Xfce default background image.


Additional info:
I found no way to depend on the flavor specific (RHEL, CentOS, SL etc.) *-logos package because they seem to have different ideas where and what the default background should be even when they all "Provides: redhat-logos", correct me if I'm wrong.

Because this seems like a bad idea to break at this point - to depend on a single path for default background image, I'm proposing to stick with the default Xfce background instead as it's better than nothing.

Attached patch fixes this issue and also drops the gnome-backgrounds dependency as they aren't visible in the background list anyway by default.

Patch also bumps the version to 4.10.3.

Comment 1 Mukundan Ragavan 2015-03-11 23:52:39 UTC
That's a fair point. I will build this.

Thanks for the report and the patch.

Comment 2 Anders F Björklund 2015-03-13 19:06:04 UTC
I think the Fedora package works around this, by using the "desktop-backgrounds-compat" package to provide the background. It cheats wildly, by not providing a background but instead symlinking to one of the large GNOME ones. But at least it follows the branding. Tried to "fix" this once, but was and is a dead-end...

Official branding is available for GNOME only (even KDE uses the default), and even that branding has some issues with paths/locations like is detailed above. There was some similar issues with LightDM looking crazy, even the "default" image isn't great always (it varies wildly between default.png/default.jpg)

Comment 3 Anders F Björklund 2015-03-13 19:08:40 UTC
Ouch, that "once" was 5 years ago already... (F11)

https://bugzilla.redhat.com/show_bug.cgi?id=490058

Comment 4 Fedora Update System 2015-03-21 21:13:28 UTC
xfdesktop-4.10.3-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/xfdesktop-4.10.3-1.el7

Comment 5 Fedora Update System 2015-04-07 17:37:37 UTC
xfdesktop-4.10.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.