This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 120102 - sgi_fam doesn't work
sgi_fam doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 20:01 EDT by Eugenia Loli-Queru
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 04:11:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2004-04-05 20:01:13 EDT
Description of problem:
Looking at /var/log/messages, I have *6 MBs* worth of the same error 
message:

Apr  5 16:39:12 duron fam[3103]: listen: Permission denied
Apr  5 16:39:12 duron kernel: audit(1081208352.562:0): avc:  denied  
{ search } for  pid=3104 exe=/usr/bin/fam name=sys dev=Untitled 1 
ino=4120 scontext=system_u:system_r:inetd_child_t 
tcontext=system_u:object_r:sysctl_t tclass=dir
Apr  5 16:39:12 duron fam[3104]: listen: Permission denied
Apr  5 16:39:12 duron kernel: audit(1081208352.564:0): avc:  denied  
{ listen } for  pid=3104 exe=/usr/bin/fam path=/tmp/.fam_socket 
scontext=system_u:system_r:inetd_child_t 
tcontext=system_u:system_r:inetd_child_t tclass=unix_stream_socket

I remember turning on sgi_fam on the Services pref panel the first 
day I installed F2t2, but haven't seen the var/log/messages log till 
today to find out that (SELinux again?) is misbehaving.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on SGI_fam in the Services pref panel
2.
3.
    

Additional info:
Comment 1 Alexander Larsson 2004-04-06 04:11:35 EDT
fam doesn't work with selinux due to the way its implemented. Thats
why its disabled by default now. If you need it you have to disable
selinux. 

We're working on a long-term fix for this, but that won't be finished
for fc2.

Note You need to log in before you can comment on or make changes to this bug.