Bug 120104 - segfault during startup when sound or usb modules loaded
segfault during startup when sound or usb modules loaded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-05 20:37 EDT by Marshall Lewis
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-06 13:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marshall Lewis 2004-04-05 20:37:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
Nautilus will segfault during startup if I load either the usb modules
or the sound modules. Runs normally (except for the fact that I have
no mouse) otherwise.

This wasn't an issue until I got kudzu working.. I'm currently running
kernel 2.6.4-1.305 prior to that I could load the usb module to get
the mouse working.  This might be related to a usb webcam I have
connect to the computer (it has a builtin mic and is detected as a usb
soundcard).  I've tried disconnecting the cam, but still get the
segfault during startup if the usb module is loaded.

my /etc/modprobe.conf currently looks like this:

alias eth0 tg3
alias scsi_hostadapter aic7xxx
alias scsi_hostadapter1 sata_via
alias If you're having problems with gated making 127.0.0.0/8 a
martian, tg3
#alias sound-slot-0 snd-emu10k1
#install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
#remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-emu10k1
#alias usb-controller ehci-hcd
#alias usb-controller1 uhci-hcd

all that is output in /var/log/messages for the segfault is:

kernel: nautilus[2526]: segfault at 00000004fffffff8 rip
000000312d46a105 rsp 0000007fbfffed70 error 4


I tried strace to figure out what it's doing, but I'm not that
familiar with the tool, and didn't see anything obvious in the
output...  Let me know what I need to do to provide you with better
information.

Version-Release number of selected component (if applicable):
nautilus-2.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. modprobe uhci or ehci or snd-emu10k1
2. try and start nautilus
    

Actual Results:  segfault

Expected Results:  nautilus loads

Additional info:
Comment 1 Marshall Lewis 2004-04-06 13:51:23 EDT
I did a clean install this morning after discovering that I hadn't
formatted the drive during my previous install ... found some extra
kernels hanging out in /boot : )

Anyway, now I can't get the behavior to duplicate.  Also, kudzu didn't
do the kernel panic thing it was doing after my previous install.. so
both issues seem to have been related to something much older on my
system.

Since I personally don't feel that you should have to support an
install (not an upgrade, an install) over top of an existing system,
I'd say it's safe to close this bug.  (I will if I can..)


Note You need to log in before you can comment on or make changes to this bug.